How do I remove things from the WinXP system tray?
September 18, 2004 1:36 AM   Subscribe

How do I remove things from the system tray on my computer (running XP)? This seems like it should not be so complicated, but my searching suggests I have to edit the registry to do that. I don't even really know what that means, but just looking at the registry intimidates me. Specifically, if I can't get the computer to stop telling me when a wireless connection is or is not available, I may just go insane.
posted by Harvey Birdman to Computers & Internet (17 answers total)
One way is to go to "Start", "Settings", "Control Panel", choose "Taskbar and Start Menu", select "Customize", click on the item, and choose "Always Hide".

Or go to "Start", "Run", type in "msconfig", ("ok"), select the "Startup" tab, and deselect the item, ("ok").
posted by taz at 2:28 AM on September 18, 2004

Re: wireless annoyance

Double click the icon in the tray that corresponds to your wireless adapter (looks like two screens together), then select the advanced button. You can deselect "Show icon in notification area when connected" from the general tab. Also, you may want to disable "Use windows to configure my wireless network settings" if you're using some other program to manage your wireless.

If those don't work and you're really annoyed, you can squash that bug with a bulldozer by completely disabling balloon style popups in windows.
posted by mrgavins at 2:44 AM on September 18, 2004

Also, to get rid of any applications that start up unnecessarily (and possibly clutter the system tray), try Startup Control Panel.
posted by mrgavins at 2:45 AM on September 18, 2004

Do you want to remove it, or do you just want to hide it?

In XP, to hide icons, do the following (from
To manage this area, simply right click the Taskbar, and choose Properties. In the Properties window that appears, on the Taskbar tab, check the box next to "Hide Inactive Icons" if it isn't already checked, and then click the "Customize..." button. That will bring up a window that allows you to choose one of three behaviors for each program icon that appears in the system tray: "Hide when inactive," "Always hide," or "always show."

To stop programs from running, click on Start, Run, and type "msconfig". programs can be flagged as "Do not run" from here.

Actually, this is pretty much what taz said.
posted by seanyboy at 3:15 AM on September 18, 2004

You can also go into the system registry to do this, though it's much hairier. (Harryer? Harrier? Hairyer? Goddamn spell-check is on the fritz right now).

Start Menu -> Run Program -> "REGEDIT"

What you'll be presented with is a giant heirarchy of configuration settings. The folder you're interested in is located here:


Delete the keys you don't want to run. But beware! You can really fuck up your computer if you screw up or pick the wrong folder. Don't worry, it's not as scary as it sounds!
posted by Civil_Disobedient at 3:33 AM on September 18, 2004

In the same vein as what Civil_Disobedient suggested go to that same registry entry and from the menu choose File/Export and save it as oldrun.reg, (the .reg will be the default extension), at which point you can pretty much delete away. If you delete more than you intended you can reintroduce the entire original list by double-clicking on that .reg file you saved.

It sounds a bit intimidating but in reality as long as you stay in that folder the worst that will happen is something won't run at startup.

Good luck.
posted by geekyguy at 7:18 AM on September 18, 2004

I personally use TraySaver which will hide the icons from your taskbar all-together. I use it for processes like really long downloads or something I'll never look at.
posted by jmd82 at 8:12 AM on September 18, 2004

Is there any good reason to do this from the registry? I'm not being snide, I'm just wondering for my own edification.
posted by taz at 8:13 AM on September 18, 2004

Thank you all very much-- I went with seanyboy's method, which seemed to solve the problem. I hadn't encountered the "overzealous notification" problem until I got my present laptop which has wireless capabilities built in....funny, no one ever mentions that in the "disadvantages to built in wireless" conversation...
posted by Harvey Birdman at 9:44 AM on September 18, 2004


not really. if you dont know what your doing you can screw yourself up pretty badly. best advice is to stay away from the reg unless you're completely comfortable doing so.
posted by bob sarabia at 9:52 AM on September 18, 2004

The registry is somewhat complex and not that easy to understand for some. Also, it's not the only place that things can be set to run at startup. That's why I recommended Startup Control Panel, cause it does all the registry edits for you and allows you to easily disable/enable/delete any entry, including some that are not in the registry.
posted by mrgavins at 11:58 AM on September 18, 2004

question: do you use wireless networking at home? this post assumes you do, and you just want to get rid of those popups that come up.

there is, indeed, a much easier version of solving this problem. no regedit required. i'm assuming you're using the windows xp built-in wireless component (called "wireless zero config"). to solve this problem:

1. Open the "network connections" page. there are many ways to do this:

click start->control panel
(or maybe start->settings->control panel)
double click on "network connections"


right click on the icon in the system tray that's making all the "noise". one of the options should be "open network connections"

2. once you have the "network connections" page up, right click on the "wireless network connection", and click on properties. A new window pops up titled "Wireless connection properties" or something similar. On this first page, the general tab, at the bottom there are two checkmarks. one is "show icon in the tray when connected" and the other is "notify me when this connection has limited or no connectivity". you probably want to deselect both of those. You can do this to every wireless connection if you have more than one.
posted by escher at 12:26 PM on September 18, 2004

oh, and if you don't use wireless networking, then the easy way to solve the problem is:

once you're on the "network connections page" (see above post), right click on the "wireless network connection" icon, and choose "disable".
posted by escher at 12:27 PM on September 18, 2004

Is there any good reason to do this from the registry? I'm not being snide, I'm just wondering for my own edification.

Yes. Just because you hide the system tray icons, doesn't mean those programs aren't still running. If you're a system resource miser like myself, you want only those things in the tray that have to be there.
posted by Civil_Disobedient at 12:52 PM on September 18, 2004

So, turning off an item in "Startup" using msconfig doesn't keep it from running at start up?
posted by taz at 2:06 PM on September 18, 2004

taz: turning off an item in "startup" in msconfig definately stops it from running at startup. problem is, a lot of things don't show up in that list. only "normal" applications show up in that list, but some applications are not normal- they run as a "service". services start up even before you login to windows, and are managed completely different from "normal" applications.

for example, the "wireless zero config" portion of windows runs as a service, and you'll need to stop the service in order to stop it from running. you can't do that from the "startup" tab in msconfig. you can, however, from the "services" tab in msconfig. another example: norton antivirus uses services, as do many antivirus applications.
posted by escher at 4:07 PM on September 18, 2004

Yes, turning it off in msconfig is stopping it from ever starting. seanyboy's first tip is the one that just hides it.

I know I sound like I'm beating a dead horse here, but I feel that I should stress (again) that using Startup Control Panel is by far the easiest, most effective, newbie-friendly way I know of controlling which apps run at startup (and possibly show up in the tray). And no, I'm not affiliated with it in any way.

[On preview: Escher is right about services... For those, go to Start-> Run, type in "services.msc" and press enter. Try to avoid using msconfig to manage services.]
posted by mrgavins at 4:15 PM on September 18, 2004

« Older Mail Duplicates   |   Bullet the Blue Sky Newer »
This thread is closed to new comments.