First They Came For The Keyboard Shortcuts, And I Did Not Speak Up, Because I Was Not a Shortcut
September 6, 2008 5:54 AM   Subscribe

For some reason, my MacBook pro suddenly won't let me use standard shortcuts- i.e. cntrl-x for cut, ctrl-v for paste, etc.- on any program, including MS Word and web browsers.

I've never had a problem with this, and didn't have to set up these shortcuts when I got the computer. I've checked system preferences and made sure the "shortcuts" option is set to default, but to no avail. It's driving me crazy to have to use the drop-down menus to cut and paste. Any idea what might be wrong?

Possible troubleshooting:
The only new software I've installed is the new version of Firefox.
I just returned from Spain and was using different wireless connections there- however, I did not encounter or download any suspicious files.

Yes, I know these sound like unlikely candidates for causing the problem I just wanted to give you the complete lowdown.

Thanks!
posted by foxy_hedgehog to Technology (9 answers total)
 
If your in OS X you know the short cuts use command, not ctrl...? You probably meant to say command I guess, but I thought i'd mention it!
posted by lukeo05 at 5:59 AM on September 6, 2008


Has your keyboard layout changed recently? If it moved the location of the Command key somehow, that would cause all sorts of things to break.

If you open TextEdit and then press Command-Q, does it quit? Or is it just Clipboard shortcuts that are broken?
posted by crysflame at 6:51 AM on September 6, 2008


I had a friend that had a similar problem, and it turned out that one of the keys (the right alt key I think) was stuck in a down position as though it were being continually pressed. Of course this had the result of causing different actions than the one intended. But is it possible that you have a sticky key?
posted by squarehead at 7:03 AM on September 6, 2008 [1 favorite]


Yes, thanks, I meant "Command," sorry!

Squarehead, with all this travel and typing whilst eating mariscos and drinking sangria etc, I think I may very well have a sticky keyboard.



...Yes, I did! High technology bows low once again to primitive snacking habits. Thanks everyone!
posted by foxy_hedgehog at 7:10 AM on September 6, 2008


cntrl-x for cut
well, copying is cmnd-c. it's one letter to the right from x.
posted by krautland at 7:19 AM on September 6, 2008


Have you checked to see if you've turned on sticky keys? (universal access prefs).
posted by bonobothegreat at 7:36 AM on September 6, 2008 [1 favorite]


This happens a lot. You have accidentally turned on numlock.
If I'm right, your F6 key will be lit up. Just press F6 to turn it off.
posted by w0mbat at 9:49 AM on September 6, 2008 [1 favorite]


Ok. Let's test those keys!
System Prefs: International Prefs: Input Menu tab: Show input menu in menu bar.

Make sure the keyboard viewer is selected
Then on your menu bar open up the keyboard viewer.

Test your command, control and opt keys.

If they don't respond, something's wrong with them. If they don't work, you have your answer.
posted by filmgeek at 10:46 AM on September 6, 2008 [2 favorites]


> For some reason, my MacBook pro suddenly won't let me use standard shortcuts- i.e. cntrl-x for cut, ctrl-v for paste, etc.- on any program, including MS Word and web browsers.

Long shot, but System Preferences > Keyboard > Keyboard tab > "Modifier keys" button. Do they all match up with what they're supposed ot be?
posted by WCityMike at 6:50 AM on September 7, 2008


« Older What are some benchmarks in the history of online...   |   Grecian 2000 Newer »
This thread is closed to new comments.