How do I make full screen applications stop stretching on wide screen LCD?
August 26, 2008 6:27 PM   Subscribe

How do I make it so that full screen applications won't stretch on my new wide screen LCD?

I got an EEE PC 900 and put windows xp on it.
I installed a couple of games, but I find it extremely annoying that they stretch to fit the whole screen.
Is there a way to make it so that it won't anymore?
posted by PowerCat to Technology (5 answers total) 1 user marked this as a favorite
 
Some games have a 'widescreen' setting. Others let you set a screen resolution to match the aspect ratio, even if it's not as high as the one you use normally.

Which games?
posted by holgate at 8:38 PM on August 26, 2008


I had the same problem with Microsoft's "Pandora's Box" and with the updated Windows version of Myst. No widescreen choice; they just take over the screen and set it to the display resolution they know about, irrespective of whether that matches the aspect ratio. (In the case of "Pandora's Box" they set the display to 800*600. On my 8:5 LCD display (native resolution 1920*1200), it looks terribly stretched horizontally.

Like PowerCat, what I want is a way to tell Windows, "Even though this game wants to run full-screen, run it in a window instead." Is there any way to do that?

But I'll settle for "full screen except don't use the full width, so that the aspect ratio remains correct."
posted by Class Goat at 8:47 PM on August 26, 2008


Best answer: Hard to say with laptops but most widescreen monitors have onscreen controls to enable/disable scaling & stretching. Failing that, most video cards' control panels also have similar settings.
posted by chairface at 8:54 PM on August 26, 2008


Response by poster: The games I'm running are diablo 2, starcraft and half life.

D2 can be windowed, but I'd rather it be full screen.
Starcraft runs at low res and I think half life has a wide screen setting, I forgot.
posted by PowerCat at 9:15 PM on August 26, 2008


Response by poster: chairface had it.

The first time around, I only installed the drivers, not the utility.
After installing the utility and drivers, I found the option to stop the application from stretching.

Thanks!
posted by PowerCat at 9:26 PM on August 26, 2008


« Older Do-My-Kid's-Homework-Filter   |   How can I get AmEx to stop sending me so much junk... Newer »
This thread is closed to new comments.