Skip

Quickbooks 2008 removes write permissions on the Samba share
August 5, 2008 8:13 AM   Subscribe

XP client removes write permissions on Samba share

This is a Samba 3.0.25 running on a CentOS 4 box. The XP client is removing the write permissions for some files in one of the Samba shares upon exiting an application (Quickbooks 2008) accessing those files.

Any ideas on how to fix this? Yes, I'm aware that Intuit doesn't support this configuration.

The configuration for that share is:

path = /home/quickbooks
writable = Yes
browseable = Yes
force create mask = 0660
force directory mask = 0770
oplocks = no
force group = qb_grp
valid users = @qb_grp

Thank you for your help!
posted by chengjih to Technology (3 answers total)
 
Sounds like a samba bug to me. I'd ask here.
posted by damn dirty ape at 9:05 AM on August 5, 2008


(Disclaimer - I have zero experience with Quickbooks)

It might be that Quickbooks isn't editing the files as such, but is actually removing and recreating them - I've seen this happening. In that case, the permissions of the files will be as if they'd just been newly created. Do they match files that you create manually?

If so then you can perhaps work around the problem by setting the default permissions for files that are created on the share. Your "create mask" limits the permissions so at most 0660 is possible), the "force create mode" option will ensure that at least the given permissions are used. So if you had:

force create mode = 0660
create mask = 0660

then all files would have permissions 0660.

You can play around with these to just force certain permissions - check the Samba docs.
Note that it will apply to all files on the share. If you need to limit it to subdirectories then you may have to look at file permissions and acls.
posted by OldMansHands at 10:10 AM on August 5, 2008


It turned out to be a Quickbooks "feature" since 2006 or 2007, where they've implemented a database server of some sort. The read-only permissions were set because you have to designate a "multi-user host" computer, which is the only machine that accesses those files. When Quickbooks opens the file, it changes permissions to 660 but reverts it on close to 440. The QB host computer has to have to file open for anyone else to access that file.
posted by chengjih at 12:21 PM on August 5, 2008


« Older I'll be moving to Chicago from...   |  Is there a Metafilter about se... Newer »
This thread is closed to new comments.


Post