Join 3,553 readers in helping fund MetaFilter (Hide)

Tags:

Little boxes vex me
July 16, 2008 9:17 PM   Subscribe

I'm suddenly getting little boxes of letter-number combinations in the text on my computer screen. What are they?

My Google-fu has mysteriously failed me and I don't know what I'm looking at. This one (☮) is supposed to be a peace symbol (from a blog post). [It looks like this is going to work, but on the off chance it doesn't post like I'm seeing it, it's a little square with the number 26 on top and 2E below.]

These things are starting to appear in search results and now in blogs. What are they and from whence do they suddenly appear? And why?

Many thanks.
posted by bryon to Computers & Internet (11 answers total) 9 users marked this as a favorite
 
It shows correctly as a peace sign on my end. Sounds like your browser or OS isn't displaying Unicode correctly.
posted by theclaw at 9:32 PM on July 16, 2008


It would help a lot of we knew what kind of computer you're using, and what operating system, and what browser.
posted by Class Goat at 9:42 PM on July 16, 2008


Refining my previous answer, it appears that if the font Firefox (on XP, at least) is using doesn't have the Unicode character referenced, it will display a box instead with the glyph's ID in it; in this case (262E). Either change the font that you're using in Firefox to a more Unicode-friendly font, or try installing one of the free Unicode fonts available.

Relevant Wikipedia links
posted by theclaw at 9:50 PM on July 16, 2008


It appears to be a bug/misconfiguration related to Firefox 3.
http://forums.mozillazine.org/viewtopic.php?p=3699295#p3699295
posted by cmcmcm at 9:59 PM on July 16, 2008 [1 favorite]


You may also want to check out this site, and his instructions for enabling Unicode in various browsers

Also see this site for a list of fonts on your machine that support that character (you need JavaScript enabled for that site to work) Also.
posted by theclaw at 10:00 PM on July 16, 2008


Ooh, thanks for asking this. I started seeing those around here on mefi about a week ago, and I figured people were doing some kind of html magic. It makes way more sense that it happened when I upgraded to firefox 3, because the timing coincides perfectly.
posted by vytae at 10:07 PM on July 16, 2008


I have this as well in Firefox 3. Unicode is enabled in the options and it happens in all fonts.
posted by winston at 6:50 AM on July 17, 2008


Datapoint: FF3, Ubuntu Hardy and I see a peace sign.
posted by Skorgu at 8:10 AM on July 17, 2008


From the wikipedia page on the peace sign:
In Unicode, the peace symbol is U+262E: ☮, and can thus be generated in HTML by typing x262E; or 9774;. However, many browsers will not have a font that can display it.
There's your answer. You need to install more fonts. Either fonts that are good for showing symbols or fonts specific to languages you are trying to view i.e. Japanese, Chinese, Thai (not latin)
posted by Sitegeist at 8:24 AM on July 17, 2008


Try upgrading to Firefox 3.0.1 (released today!) I did and it seemed to fix the problem on my computer.
posted by phoenixy at 7:03 PM on July 17, 2008


Related bug: If you're using FF on a Mac and the heart/lessthanthree (&heart;) symbol is not showing, switch your default Japanese font to Osaka-Mono. No idea why that solves the bug but it does, according to Bugzilla.
posted by subbes at 2:37 PM on July 19, 2008


« Older Please give me home office ins...   |  Help us to estimate utilities?... Newer »
This thread is closed to new comments.