Skip

My computer has insomnia!
May 30, 2008 1:47 PM   Subscribe

My computer won't go to sleep (suspend mode) unless the Ethernet cable is unplugged.

I have an HP Pavilion A6230N desktop, running the Windows Vista install that it came with. It is connected to a Linksys WRT54GL router with an Ethernet cable.

If I put the computer in suspend mode while the Ethernet cable is plugged in, it suspends for about a second and then powers back on. If I unplug the Ethernet cable, suspend, and plug it back in within a few seconds, it powers up within five seconds. If I leave it unplugged for a while (an hour or more), it does not power back on when I plug the Ethernet cable back in.

This happens regardless of the method I use to put it into suspend mode; I have tried pushing the "power" button on the computer and using the several different methods Windows offers. It does not power back on if I do a full shutdown.

I have gone through all the BIOS settings to make sure WakeOnLAN or anything resembling it was turned off. It already was. I am now out of ideas. What could it be?
posted by qvtqht to Computers & Internet (6 answers total)
 
compulsion to answer trumps reading ability....again. Have you tried the solutions listed here?
http://h10025.www1.hp.com/ewfrf/wc/document?docname=c00845808&cc=us&lc=en&dlc=en&product=3548196
posted by cosmicbandito at 2:07 PM on May 30, 2008


It sounds like you might have a background app that works while you're connected, so that your comp thinks some program is still actively running while a net connect is up. Check your task manager to see if anything suspicious or unrecognizable is active - you might have a virally compromised machine.
posted by FatherDagon at 3:07 PM on May 30, 2008


FatherDagon, how would that make it come up after it's been shut down? Wakening like that is a hardware function controlled by the BIOS.
posted by Class Goat at 3:53 PM on May 30, 2008


As the OP said, it doesn't do it when it's fully shut-down, only on suspend. I don't know the answer, but maybe the OS is still running to some degree while in suspend mode in order to keep things in RAM.
posted by hungrysquirrels at 5:09 PM on May 30, 2008


Background network activity is waking your computer up.

Solution from here:
In Vista:
Disable or Enable the Wake Up Computer Option
for a Device :
NOTE: Check your Network device. Network activity can cause the network hardware to wake the computer, especially when the network is always on (like cable and DSL connections). High Definition Audio may also cause the computer to wake from sleep mode.

1. Open Control Panel. (Classic View)
2. Click Device Manager icon.
NOTE: You need to be in a Administrator account.
3. Click Continue for UAC prompt.
4. Open the device's list that you want to change.
EX: Network Devices
5. Right click on device name and click Properties.
EX: Network Devices
6. Click Power Management tab.
7. Uncheck Allow this device to wake the computer.
NOTE: To Enable it again, just check this instead. If you need to disable the wireless mouse and keyboard, then you can wake the computer by pressing the power button on the case.
8. If listed, check Allow the computer to turn off this device to save power.
NOTE: This will turn the device off when the computer goes into sleep mode.

I had a similar problem - this fixed it. Hope it helps you too.
posted by sevenyearlurk at 5:27 PM on May 30, 2008


Thank you, cosmicbandito and sevenyearlurk. Unchecking "Allow this device to wake the computer" fixed it.
posted by qvtqht at 1:33 PM on June 1, 2008


« Older What are some examples of non-...   |  Looking for a good guide about... Newer »
This thread is closed to new comments.


Post