Join 3,418 readers in helping fund MetaFilter (Hide)


Why does Firefox hate hearts?
May 13, 2008 12:12 AM   Subscribe

Firefox refuses to show the heart symbol (♥) correctly. It shows up as a straight, vertical line instead. Is there anything I can do to fix it?

Whenever I'm browsing Facebook (or other websites that use the ♥ symbol, but it most frequently appears on Facebook), Firefox refuses to display the symbol correctly. It works fine in Safari. I have a Macbook with OSX 10.5, and Firefox 2.0.0.14 (should be the most recent version -- I just updated today). Is there anything I can do to make this character display properly? Its a minor annoyance, and I have at times debated whether I really want to see ♥s wherever one chooses to put them, but I figure its better than seeing a screen full of lines.

My friend also has a MacBook, using the same version of Firefox, and also has this problem. What gives?
posted by elisabethjw to Computers & Internet (17 answers total) 4 users marked this as a favorite
 
Change your default font?
posted by Class Goat at 12:14 AM on May 13, 2008


Same here actually - and I've never touched my default font, so how would it have changed?
posted by razorfrog at 12:16 AM on May 13, 2008


I'm on a Mac running the Firefox 3 beta, and the heart shows up fine.
posted by dcjd at 12:19 AM on May 13, 2008


I see the heart symbol correctly in Firefox (Linux though).
posted by null terminated at 12:19 AM on May 13, 2008


The few times I've looked, it's been due to cutting & pasting the ♥ symbol from Word / Character Map / etc, rather than using the proper HTML entity ♥
posted by Pinback at 12:25 AM on May 13, 2008


And preview strikes again - the last one should be the ampersand symbol, followed by hearts; ...)
posted by Pinback at 12:28 AM on May 13, 2008


Well I definitely have the same problem on mac/firefox. Don't have it on safari, or win/firefox.

Interesting, if I "view source" of this page, the heart shows up just great.
posted by Project F at 12:28 AM on May 13, 2008


Shows up fine for me in 2.0.0.14 on WinXP. Maybe its a Mac Fonts thing, do you know what your default font is?
posted by missmagenta at 12:29 AM on May 13, 2008


Change all your default fonts for the Japanese character set to 'Osaka'. I have no idea why this works.

For me this is Preferences: Content: Advanced: Fonts for [Japanese from the drop-down menu].

(via).
posted by Lebannen at 12:39 AM on May 13, 2008 [10 favorites]


It looks fine to me in firefox 2.0.0.14

My default font is Times New Roman.
posted by tiamat at 12:40 AM on May 13, 2008


I had the same problem until I started using the Firefox nightly builds. I'm not sure it'd be worth it to use those just so you can see the heart symbol correctly, since instead you'll get to deal with all kinds of fun, new problems (like right now, searching a page's text doesn't work at all, and hasn't for the past couple builds).
posted by Venadium at 12:44 AM on May 13, 2008


on my OSX 10.4.11-running MBP, I looked at this page in multiple browsers, (logged in and out). Login status had no effect so I've ignored those results.

Safari 3: heart symbol shows up fine.
Opera 9.27: heart symbol shows up fine.
FireFox 2.0.0.something: vertical lines (pikes, I believe they're called)
Camino 1.6 (same rendering engine as FF2): vertical lines (same as FF2)
FireFox 3 Beta: heart symbol shows up fine.

my guess is it's a known issue that will be addressed when FF3 is released.
posted by heeeraldo at 12:52 AM on May 13, 2008


Looks fine to me too, same setup as missmagenta.
posted by randomstriker at 1:07 AM on May 13, 2008


This is a very old bug with an ugly history. It is corrected by Cairo (Firefox 3.0).

If you are interested, the full details are on the Bugzilla page for 212745
posted by Lame_username at 1:11 AM on May 13, 2008


Oh yeah, and Lebannen has the best workaround until you get the new release.
posted by Lame_username at 1:16 AM on May 13, 2008


Thanks Lebannen (and elisabethjw!) - that fix worked. I've been wondering about this for ages.
posted by annathea at 1:43 AM on May 13, 2008


I | Lebannen's advice.
posted by drezdn at 6:36 AM on May 13, 2008


« Older How can i outsource my job (or...   |  On Thursday morning, I'm takin... Newer »
This thread is closed to new comments.