Join 3,513 readers in helping fund MetaFilter (Hide)


Help with Bittorrent port fowarding
May 9, 2008 9:40 PM   Subscribe

Just got Verizon FIOS and the wifi access point sucks. So I disabled the wireless portion on the fios router and plugged in a linksys wifi router. Wireless is now kick a** but my bittorrent is slow. I need help with port forwarding.

The fios router is 192.168.1.1/24 and the new access point is 192.168.1.2/24 with the wireless network being 192.168.2.0 and the computer I want to torrent on is 192.168.2.101. On the fios router (.1) I have set port forwarding for port 65473 to forward to the linksys(.3). Then on the linksys, port forward for 65473 to computer (.2.101).

>> Fios Router 192.168.1.1 > Linksys to Fios Interface 192.168.1.3 > AP 192.168.2.1 >MacBook 192.168.2.101

This doesn't work. If I plug into fios router and get into the .1.1 network, it works. How can i get wireless bittorrent working?

Fios router is an Actiontech MI424-WR. Wifi is Linksys WRT160N.
posted by nivekraz to Computers & Internet (6 answers total) 1 user marked this as a favorite
 
Try to disable NAT and DHCP on your linksys router, so that the linksys router is only acting as an access point and your wireless network is in the same address space as the wired network. Otherwise, your laptop is accessing the internet through two layers of NAT whenever it's connected to the wireless network.
posted by strangecargo at 10:04 PM on May 9, 2008


In addition to disabling NAT & DHCP on the linksys, you should connect it to the FIOS router via one of the LAN switch ports, not the WAN port.
posted by Good Brain at 10:41 PM on May 9, 2008


As described should work, as long as the macbook has its gateway as the linksys, and the linksys has the fios as its gateway. Still, two layers of NAT is pointless.

As suggested, plug the fios into the lan port of the linksys, have only one of them do DHCP and put everything in the same IP address space - 192.168.1.0/24 sounds like the best. You shouldn't actually need to disable the NAT on the linksys, you'll just not be using the WAN side of it at all. Then your macbook should be effectively plugged into the lan port of the fios router, whether it's by ethernet or wireless.
posted by ArkhanJG at 3:12 AM on May 10, 2008


Oh, and make sure wireless to lan bridging is enabled on the linksys. It usually is by default, but just in case...
posted by ArkhanJG at 3:13 AM on May 10, 2008


Lastly, put the fios as the default gateway - but I image you know that :)
posted by ArkhanJG at 3:16 AM on May 10, 2008


Thanks all you guys. I disabled dhcp on AP and plugged fios router into lan port. Everything works bangin'!
posted by nivekraz at 9:29 AM on May 10, 2008


« Older What's the best health advice ...   |  And that's very nearly the lim... Newer »
This thread is closed to new comments.