Skip

Buscar con Google!
April 16, 2008 10:14 AM   Subscribe

Help! Google thinks I am Spanish!

I live in Canada. Normally when I go to google.com I automatically get redirected to google.ca. A few weeks ago, I started getting sent to google.es instead! This happens on my Mac and on my Dell laptop booted in either Windows XP or Ubuntu. I always have firefox set to clear cookies whenever I close it, so if I set a preference with google, the next time I open firefox I am back in spanish.

This leads me to think it has something to do with my ISP (teksavvy.ca). What Is My IP Address.com locates me correctly in Canada. Why is google confused? I will call my ISP but I wanted to know if this has ever happened to you and why it happened; I am more curious about what's gone wrong then really worried about fixing it (it's helping me work on my spanish at any rate!).
posted by The Wig to Computers & Internet (6 answers total)
 
Google thinks I'm Spanish. Seems Firefox must still have his issue where it claims some people in the name of Spain.
posted by birdherder at 10:21 AM on April 16, 2008


err. Google thinks I'm Spanish. It appear the google toolbar add-on to FF makes it confused? If you don't have that installed, then I don't know.
posted by birdherder at 10:29 AM on April 16, 2008


This isn't the solution to your question, but it peeves me to no end that Google automatically redirects to the local Google page. So, for posterity:

Using http://www.google.com/ncr will always give you the generic Google page.

Not at all the answer you were looking for, so feel free to flag this comment for removal.
posted by lioness at 10:34 AM on April 16, 2008


All I have is the search bar that gomes with firefox these days. Automatically searches google, yahoo, etc etc. As I understand it, that's not the google toolbar.
posted by The Wig at 10:34 AM on April 16, 2008


Try here for Google's notes on this issue.
posted by le morte de bea arthur at 10:48 AM on April 16, 2008


I had this problem a couple of weeks ago. One day Google suddenly decided my IP address was in Spain. I got back to English google by setting my interface language, but I was still getting Spanish help text on other Google properties like Blogger.

The problem disappeared a couple of weeks later. Same IP address still, so I'm guessing it was a Google bug.
posted by Nelson at 1:51 PM on April 16, 2008


« Older Moving a stove or shelf across...   |  Design-pattern (programming) q... Newer »
This thread is closed to new comments.


Post