Join 3,512 readers in helping fund MetaFilter (Hide)


Laptop Wi-fi thingy problem
March 13, 2008 2:27 PM   Subscribe

I have Xubuntu, a DWL-G650 wi-fi card, and an Airport Express base station. How do I get them to love one another?

I installed Xubuntu on an old Compaq Presario lappy. Everything works fine but for the internet connection.

The computer recognises the network name but refuses to connect to it.

On selecting the network, I get a window:

Passphrase Required by Wireless Network

It asks me to choose the type of wireless security (I select WEP 128-bit Passphrase as this is what I configured using my iBook) and asks me to enter the passphrase. It also asks me for the type of authentication I want to use: Open System, or Shared Key (I have no idea what that means).

When I type my password in and press enter, a swirly animation suggests it's trying to open the connection but a few moments later the password screen returns and I'm back to square one.

I've checked and double checked the password. I've reset it several times, just to make sure.

I'm technically challenged, and I'm stuck. What am I doing wrong? What should I be doing?
posted by popcassady to Computers & Internet (10 answers total)
 
Can you check again on the base station and be sure it's WEP 128? Newer equipment like the Airport Extreme should support WPA, and you should use that instead.

You are also using Shared Key instead of Open System, and the passphrase is what you typed in on the base station.
posted by odinsdream at 2:50 PM on March 13, 2008


Okay, this is strange... I seem to have a connection. I used Shared Key (although I definitely tried it before -- must have missed something subtle) and now it seems to have a connection. At least, that's what I assume the 'reception bars' icon is suggesting.

But still, Firefox is having difficulty. It keeps telling me: Server not found.
posted by popcassady at 2:59 PM on March 13, 2008


Having a connection but not being able to browse probably means you're not getting a DNS setting via DHCP. Try to ping a fixed IP address like whatever computer you're posting from. If that works then it's a DNS issue.
posted by GuyZero at 3:07 PM on March 13, 2008


I just tried pinging various IP addresses and kept getting: connect: Network is unreachable.
posted by popcassady at 3:35 PM on March 13, 2008


Oy..I just went through a similar nightmare w/ Ubuntu and Fedora last week (more due to Broadcom firmware issues).
What does iwconfig show? You probably aren't associating with the router properly. Also, what rev of your wireless card do you have? Check the revision here.
posted by Cat Pie Hurts at 4:45 PM on March 13, 2008


Thanks for the help... I finally stumbled upon a solution.
posted by popcassady at 4:46 PM on March 13, 2008


Er..I missed the technically challenged part. Open a terminal window and type "iwconfig". This should give you the status of the wireless extensions.
posted by Cat Pie Hurts at 4:46 PM on March 13, 2008


popcassady - cool..what fixed it?
posted by Cat Pie Hurts at 4:46 PM on March 13, 2008


...my main problem was the DNS settings. I changed them to the ones set for my router.
posted by popcassady at 4:46 PM on March 13, 2008


For what it's worth, a good IP address that you can easily remember when testing stuff is 4.2.2.1 or 4.2.2.2. Both of these are Verizon's DNS servers. If you can ping them but not, say, google.com, then DNS is probably faulty somehow. If you cannot ping them, you aren't connected to the internet.
posted by odinsdream at 5:38 PM on March 13, 2008


« Older Which domain auction house is ...   |  What can I do in the short and... Newer »
This thread is closed to new comments.