How do I force Firefox to cache PNG files?
March 12, 2008 12:03 PM   Subscribe

How do I force Firefox to cache PNGs?

So there's a website that I visit from which I was recently blocked due to excessive hits against the server (something painful like 90+ hits per minute over 30+ minutes). I checked with the site administrators, and after going through their server logs, they reported there were a "lot of PNG files being opened over and over again," and that they (PNGs) probably weren't being cached properly.

Further they told me that:

In Firefox, the default action for PNG files is to open them using QuickTime instead of SaveToDisk. You will need to change the default action to SaveToDisk as there were a lot of files with PNG extensions in your log file. They may not have been cached properly which could have caused all the hits against our site because Quicktime was intercepting the default action.

This seems a little hand-wavey to me -- I guarantee I'm not the only person using Firefox on this site, and to complicate things a bit further, I don't even have QuickTime installed on this computer.

Can anyone else think of anything that would cause my computer to not cache PNG files correctly? I'm using Firefox 2.0.0.12 on Windows XP SP2, and don't have any extensions installed that aren't too off the wall (AdBlock Plus, NoScript, del.icio.us, Firebug, Google Browser Sync, Sage, Web Developer, ChatZilla).
posted by Doofus Magoo to Computers & Internet (2 answers total)
 
The Web Developer toolbar lets you disable caching. Is it possible you've done so?

It sounds like the site administrators are ... confused, to me, but then I'm no expert in Firefox internals.
posted by enn at 12:08 PM on March 12, 2008


The Web Developer toolbar lets you disable caching. Is it possible you've done so?
(Slaps forehead, slinks away)

enn, if you're ever in Harrisburg, email me and I'll buy you a beer.
posted by Doofus Magoo at 12:10 PM on March 12, 2008


« Older How to accept love?   |   David Kelly and Dad Newer »
This thread is closed to new comments.