Join 3,416 readers in helping fund MetaFilter (Hide)


Subaru running in stealth mode. Need help.
February 23, 2008 11:31 AM   Subscribe

What might cause the running lights of a 1992/3 Subaru Legacy to all be out. I can't seem to locate a blown fuse.

I have a 1992/3 subaru legacy. I recently removed the FWD fuse from it's engine compartment and shortly thereafter got pulled over for not having running lights. My headlights work and my brakelights work. I have looked in the "main fuse box" above the battery in the engine compartment, but nothing there seems to be blown.
posted by SECONDHANDSMOTE to Travel & Transportation (4 answers total)
 
Did you put the FWD fuse back in?
posted by Thorzdad at 11:35 AM on February 23, 2008


Is there a second fuse box somewhere, maybe under the steering wheel?
posted by box at 11:36 AM on February 23, 2008


Thorzdad - yes, I put the fuse back in but the lights remain out. I've left it out since then however.
box- I looked under the dashboard, and even got into it with a screwdriver (there's no obvious door) and all I see is a bunch of the wiring, no fuses.
posted by SECONDHANDSMOTE at 12:04 PM on February 23, 2008


I've got the same car, same year. There is a fuse box in the engine compartment, and there is a fuse box under a kick panel on the driver's side. Next to the door, up near the clutch, where you see the bundle of wires disappear behind the plastic.
posted by kuujjuarapik at 1:53 PM on February 23, 2008


« Older Is it necessary or worthwhile ...   |  Is there a doctor in Los Angel... Newer »
This thread is closed to new comments.