Join 3,422 readers in helping fund MetaFilter (Hide)


Wireless router won't let me connect.
July 2, 2004 9:28 AM   Subscribe

Cable Modem issue. When I am hooked up to good old Comcast through my Motorola Surfboard modem using the USB connection, life is great. Flawless internet surfing. But recently I decided to hook up a wireless router and spread the love throught the house. Problem: My modem won't recognize a connection with the network adapter connection.

I have a Dlink DFE-540TX adapter. All is well with it, according to MS Device manager.
The modem shows by its flashing little light that it has PC activity. But when I open a browser I get nothing but DNS errors. I need the ethernet connection to set up the wireless modem (Dlind DI-514).
I have updated the driver to the network adapter. I have uninstalled any and all the Surfboard modem drivers. Nothing.
So I revert back to USB and connect to the web and stare angrily at the new router/access point box knowing there is only little mystery thing I have missed in the connection.
Any ideas?
posted by majikwah to Computers & Internet (13 answers total)
 
Do you need a crossover cable between the network adaptor and the cable modem, perhaps?
posted by ph00dz at 9:39 AM on July 2, 2004


Did you set up the wireless router properly? Did you tell the router its IP address and the DNS server address?

Did you set up your PCs to use DHCP and dynamic DNS?
posted by falconred at 9:54 AM on July 2, 2004


Yeah, I need a crossover cable. I hook the modem to the router, then the router to the adapter. No good.
So I back up and see if it is just the modem and try that. Hook the modem to the adapter. no good.

Hmmmm, DHCP and dynamic DNS. I'll try that, however I used a cable modem in the past through the network adapter, all was well. But now, with Comcast that same set up isn't working. Only change in the system was moving to Comcast.

I haven't even got to the point of setting up the router yet, as I can't get the modem to communicate to the computer through the ethernet link - with or without the router.
posted by majikwah at 9:59 AM on July 2, 2004


What wireless router did you get?

The best way to set it up is to do a hard connect to one of the wireless router's ethernet ports. From there, you can use a browser to log in to the router's admin pages (e.g., Dell routers use http://my.router).

Set up the wireless router.

Usually it's also good to set internal IP addresses for each computer and only grant access to these computers (set via the ethernet card MAC address), to restrict access to your router.
posted by linux at 9:59 AM on July 2, 2004


More:

Does the wireless router manual give you default DNS info? Change your network adapter's settings to whatever it gives you (more than likely the IP is DHCP).
posted by linux at 10:03 AM on July 2, 2004


FWIW, I have the same problem with the same modem on Roadrunner (sans the router, just modem to PC) and have never solved it. The result has been the same on my desktop and my laptop, under Redhat 8, Redhat 9, and Windows XP, and using a variety of NIC cards. USB works fine in both Linux and Windows. The modems are shite is my opinion but I'd be thrilled to be proved wrong.
posted by IshmaelGraves at 10:33 AM on July 2, 2004


The modem may be locked to the MAC address of your computer. I have no idea how/whether that would be accomplished via the USB port, but possibly the driver assigns one or something else happens to lock the modem to one computer. If you can find out what MAC the modem sees when your computer is connected, you can probably have your router use that address to talk to the cable modem. You might have to call up Comcast and have them re-provision your modem to use the router's MAC address.
posted by kindall at 10:45 AM on July 2, 2004


Ok, so you want to connect your new router directly to your cablemodem, right?

AFAIK, Comcast registers the MAC address of the hardware you have when you first connect. Comcast will currently only accept traffic from the MAC address they know about. Your router has a different mac address.

You have two options if my diagnosis is right.

1. Your router may have a configurable outward-facing (WAN) MAC address. Check the admin settings. If so, set it to the MAC address that your working machine shows on its active network adapter when it's hooked up via USB (look in network properties or run ipconfig). Make sure not to change the inward-facing (LAN) MAC address to match, as you will create a MAC address conflict.

or 2. Call comcast and tell them you need to change your MAC address, and give them the outward-facing MAC address of the router. If nothing else, it should be on a sticker on the thing.

Not all cable companies do this, but I know that comcast did and I assume that they still do.
posted by ulotrichous at 10:53 AM on July 2, 2004


Thanks. I'll give that a try.
posted by majikwah at 12:19 PM on July 2, 2004


Yeah, and just tell them you got a new ethernet card. Do not tell them it's a wireless router.
posted by linux at 1:18 PM on July 2, 2004


wow, I new I would get the answer but you guys are just great.

It was the DHCP stuff.

I unplugged everything. I went into the ipconfig /release and then /renew and rebooted.

Then I reconnected everything in the right order (pesky that is) (router, modem, computer) then restarted and voila! I am back on line and the router is working.

A few points and clicks on the install software and the home wireless network is finally working.

Thanks Meta wizards. I may just have to quit lurking.
posted by majikwah at 2:37 PM on July 2, 2004


Ulot: I have Comcast [Detroit area]. I have used at least three different MAC addresses [my CPU, then my Linksys 10/100 router, then my Netgear wireless router] and never had a problem getting through.

However, my IP address did change with each change in MAC [although my service is Dynamic IP, it has rarely, if ever, actually changed without a change in MAC address]. But that shouldn't affect your average surfer and community weblog poster.
posted by britain at 3:17 PM on July 2, 2004


Not to pile on too much here, especially since it seems the question was answered, but for the next person who has a similar problem, cloning a MAC address may also be required with some provider/hardware combinations. Took me a day or two to figure that out. Maybe this can save someone a couple minutes of that time.
posted by Sinner at 12:00 AM on July 3, 2004


« Older Beach umbrellas. I'm going dow...   |  I compute and play music in th... Newer »
This thread is closed to new comments.