Why does pasting excel charts into word cause the word file to become gigantic?
June 24, 2004 8:45 AM   Subscribe

Is there a way to cut'n'paste charts from Excel into Word, without generating huge Word files? I've tried varieties of paste, 'paste special,' and so on, and I can't figure out why an Excel file of charts that's several hundred KB, always turns into a Word file that's at least several MB. I guess I'm missing something obvious, but have no idea what it is.
posted by carter to Technology (8 answers total)
 
Two things spring to mind:

1. Paste it as a link.
The downside would be that you'll have to distribute both files for it to work properly.

2. Paste it into a graphics package and save as a GIF before importing that file into Word.
The downside would be that it'll have all the restrictions of being an image (can't be edited or updated) but it should make the Word document size much less.
posted by ralawrence at 9:03 AM on June 24, 2004


Or you could save it as HTML, throw away everything except the graph and then in Word do Insert--> Picture--> From File
posted by golo at 9:13 AM on June 24, 2004


I think when you cut it out of Excel and paste it into Word, it's turning the image into a .BMP file, which are huge. You should do as ralawrence suggests and turn it into a GIF using some graphics program.
posted by falconred at 9:51 AM on June 24, 2004


Yes! golo's suggestion generates a page of html, and a related folder of images to be loaded into that page; and all the images in the folder happen to be nice small GIFs, which I can then pick and choose from. Thanks, all!
posted by carter at 10:14 AM on June 24, 2004


What you're doing by cutting and pasting is actually embedding the whole excel file into the word document. If you're working with a large spreadsheet this can balloon your word document very quickly. Also, since word keeps and saves your undo information, if you cut and paste multiple times, each seperate action increases the size of the word document.

We found this out the hard way when we discovered several smallish documents that were larger than 100 MB each. Turning off the save-the-undo "feature" cut the file sizes back by better than 90%. I'm pretty sure it's the "fast save" option on the save tab of the word options that caused the problem.
posted by bonehead at 11:44 AM on June 24, 2004


Win XP? Paste it into MSPaint.exe, select all and copy. It pastes as a JPG.
posted by tomharpel at 9:25 PM on June 24, 2004


Try this:

1. In Excel, hold the shift key down
2. Click the chart
3. From the Edit menu, select Copy Picture
4. Switch to Word.
5. From the Edit menu, select Paste.
posted by Izzy at 11:46 PM on June 24, 2004


Rule of thumb with picture formats:

Avoid JPEG's unless you are working with photographs.
Avoid GIF's if you are.
posted by ralawrence at 1:54 AM on June 25, 2004


« Older Why are voiced-over translatio...   |  I'd like to find a good map/at... Newer »
This thread is closed to new comments.