Skip

my simple two computer network stopped working and I don't know why, do you?
January 10, 2008 5:41 PM   Subscribe

I use to have a home network and now I don't. Why? Google turns up many similar problems and a few answers but no solution that works for me.

Two computers running windows XP pro connect to the internet through a residential gateway [computers ----> workgroup switch ----> residential gateway ----> dsl ---> world]. I put both computers in the same work group, enabled simple file sharing, made 'my documents' on one shared and could read/write from the other. Then one day I couldn't and nothing I've done, re-sharing the directory, running the network wizard and using a different work group name, enabling/disabling the firewall, nothing has restored the ease of access, or any access, instead I'm told "\\computerName-35cbba is not accessible. You might not have permission to use the network resource. Contact the administrator of the server to find out if you access permissions. Access is denied." To which I say arrrrgh. Anyone know what's happening here, and why, and how to fix it? Thanks.
posted by Grod to Computers & Internet (7 answers total) 1 user marked this as a favorite
 
Find out the local IP address of each computer.
Make sure they are in the same subnet.
Make sure they can ping each other.

Make sure to take any 3rd party software into account (like Norton internet security)
Try accessing the shares by \\ip.ip.ip.ip instead of the hostname
posted by TravellingDen at 6:04 PM on January 10, 2008


192.168.0.2 and .3 respectively, ping no problem. from 192.168.02 (with xampplite and mysql services stopped and no third party firewall running or anything else that might possibly get in the way) I entered this into explorer "\\192.168.0.3" and get the same access denied except in place of 'computerName' is the ip address. Going the other direction, from 192.168.0.3 to 192.168.0.2 I am prompted for a password for guest, which shouldn't happen, that computer has no guest account. When I turned on the guest account and left the password field blank access was denied. All I want to do is access the contents of one drive from either computer.
posted by Grod at 7:02 PM on January 10, 2008


I'll be watching this thread, I recently re-installed WinXP Pro on my wife's computer, and my network setup it about identical, and I'm seeing the same thing. It really has me puzzled.
posted by jrishel at 5:20 AM on January 11, 2008


If you need to share things right now, you might just put an FTP server on the machine from which you want to share files.

To diagnose your problem, I suggest the following steps:

Look in the event log for the sharing computer around when this stopped working.

Attempt to connect to your share from the machine that has the share.

Scan the listening ports on the server from the client. You can use something like nmap for this. See if the ports for NetBIOS over TCP/IP (TCP/135, UDP/135, TCP/137, UDP/137, UDP/138, TCP/139) and/or DirectHost SMB over TCP (TCP/445, UDP/445) are listening.

Connect the two machines directly with a crossover cable. Each machine should give itself an APIPA address (169.254.0.0). See if you can connect, etc, then.

Run the Local Security Policy tool (from a command prompt, type "secpol.msc", or choose Local Security Policy from the Administrative Tools folder within Control Panel) and ensure that no IP security policies are enabled. Also, while you're there, go to Local Policies ... Security Options, and reduce your Lan Manager authentication level to "Send LM and NTLM responses".
posted by me & my monkey at 7:08 AM on January 11, 2008


Do logged accounts on each machine have passwords?

Some setups automatically deny users with no password set.

Also, are you logged in with the same username but different password? That can also cause havoc.
posted by mphuie at 9:44 AM on January 11, 2008


I'm not sure if this will solve your problems, but I've found the information HERE to be helpful in the past when trying to share files on an XP network - which has always been a nightmare.
posted by CorporateHippy at 12:11 PM on January 11, 2008


jrishel and anyone else who, like me, was brought to the verge of kicking cats (I like cats) out of pure frustration, here is what finally worked for me. I began to reason thus: security is a bitch. Fuck it. But maybe, hey, grod, what if I changed a setting in the last x months and promptly forgot? I have no memory for my own actions, past, or anything else, really, so this is very probable. If I did this then I need to undo it, but what was it? Fuck it, there must be a reset switch somewhere. There is? Amazing. I'll try that.

The reset switch for XP security is described here: http://support.microsoft.com/kb/313222. I did that but I didn't reboot, instead I took a shower, forgot I'd done it, remembered, tried to connect, found I couldn't, raged impotently, got a cramp, took a deep breath and gave up, again. Then I searched for another solution, again, once more, as it were. Sigh, said I, fuck and damn and blast, said I, seven pages into search results. Here's what I ultimately did, it worked (unless it was the security settings being reset), I don't know why it worked. I'm not responsible if your computer becomes an iguana and starts eating your furniture nor even if it stops working. Take salt and try this:

If you haven't used regedit stop reading.

firstly winkey+r = start > run, either way launch 'cmd' and type 'ipconfig /all' find the line that says 'Node Type dot dot dot : unknown'. If it says 'hybrid' on the machine you can't reach then I'm afraid I can't help you. If it says something other than 'hybrid' (e.g. 'unknown') then try this, run -> cmd -> regedit navigate to HKEY_LOCAL_MACHINE > SYSTEM > SERVICES > NetBT > Parameters and create a new DWORD called 'NodeType' then set the value to '8' (stay in hex). reboot. For good measure try it on your other machines. I don't know what it does but it hasn't hurt anything. Not yet, anyway. Reboot those, too. Pray to your local cat deity and try to connect to a share. If it works, you're welcome, if it doesn't, you didn't hear it from me. I'm too pleased for my own good let alone yours, don't go entrusting your network to my clumsy fingers. Geez.

Cheers.
posted by Grod at 8:04 PM on January 14, 2008


« Older I'm a big fan of Dengue Fever,...   |  What did they use to make that... Newer »
This thread is closed to new comments.


Post