Skip

WP Blog gone blank, Admin section is fine
January 6, 2008 3:53 PM   Subscribe

WorpressFilter Blog gone blank, Admin section is fine - help !

I've upgraded my Wordprees blog to the latest version and all hell broke loose on me... First it was a full blatk blog and admin section. I've regained access to the admin section by deleting a theme folder but there is still a white page where somebaudy.com used to be

Deleting the content of the plugins folder did not help.

if it's of any help I'm hosted by DreamHost
posted by Baud to Computers & Internet (8 answers total) 2 users marked this as a favorite
 
Did you do something to your htaccess file? The page source for your site is completely blank.
posted by maxpower at 4:01 PM on January 6, 2008


I just updated, and had the same problem. The placeholder index.php that's left at the root of the blog isn't the one you need.. In my case, it was probably because I didn't fully read the instructions, and neglected to run their update script.
posted by dws at 4:09 PM on January 6, 2008


I just checked out a fresh download of the latest wordpress. The index.php in wp-content (the one with the "silence is golden" comment) isn't the one you want to end up with, as it will show as blank. The index.php at the top-level (with the "short and sweet" comment) is the one that works. At least, that was my problem; you may have run into something else.
posted by dws at 4:35 PM on January 6, 2008


Just to be clear, "silence is golden" isn't what you want in the root, but that index.php is what you want in wp-content, to keep that folder invisible to prying eyes.
posted by dws at 5:45 PM on January 6, 2008


Also, check your error.log file (should be in /home/username/logs/sitename/http/error.log) for PHP errors. Sounds like you might find some clues there. Normally when this happens, the PHP errors are turned off and don't show up, just a blank page does.
posted by cdmwebs at 6:31 PM on January 6, 2008


"silence is golden isin wpvontent", "short and sweet" is in the blog root. I'm investigating the htaccess clue
posted by Baud at 1:26 AM on January 7, 2008


Worst case, you can go into phpmyadmin and backup your mysql database, then download your wp-content/themes and wp-content/plugins, then delete and reinstall.

sounds like a php error to me, though. you might try downloading then deleting all your plugins until it starts working.
posted by softlord at 4:05 AM on January 7, 2008


in wp_options database, something called gzip compression was causing all the fuss! Once set set to "disabled" everything was back to normal.
posted by Baud at 5:55 AM on January 8, 2008


« Older [Washington State Law question...   |  I am currently involved in set... Newer »
This thread is closed to new comments.


Post