Join 3,436 readers in helping fund MetaFilter (Hide)


Please help my dock and apps play nicely together
December 20, 2007 6:15 AM   Subscribe

On my Mac (Tiger), I prefer to have the dock at the bottom, hidden. But all my applications insist on opening new documents and windows so that the new window touches the bottom of the screen. As a result, it often happens that when I go to resize the window by grabbing the bottom right corner, I invoke the dock instead. Usually, a second try will be successful, but this is annoying as heck. Is there a global setting that will tell my applications to stay out of that last quarter inch of my screen? Or some other solution to this?
posted by bricoleur to Computers & Internet (12 answers total) 2 users marked this as a favorite
 
That has annoyed me as well. I run my dock on the left, but the only thing that seems to work is to turn off auto-hide. The dock will always be visible, but new documents will not overlap the dock real estate.

Maybe someone else has a better solution.
posted by The Deej at 6:25 AM on December 20, 2007


This is why I run my dock along the left side of my screen. I don't really know of any other solution, sorry.
posted by misha at 6:52 AM on December 20, 2007


The other solution is to put the dock on the right side of your screen. This is particularly effective if your second monitor is to the left of your primary monitor.
posted by b1tr0t at 7:34 AM on December 20, 2007


Seconding dock right. But it's not going to look so great in Leopard over there...
posted by omnidrew at 7:46 AM on December 20, 2007


not a mac user, but can't you resize a window from the top edge then drag it up slightly?
posted by subtle_squid at 7:49 AM on December 20, 2007


Another annoyed user here. I just make sure I put resource hogs like Photoshop in the center of the doc so that there's less chance of launching them by accident. I don't like putting the doc on the right because even more frequently I'll knock open the dock when trying to use the scroll bar.
posted by cocoagirl at 7:53 AM on December 20, 2007


subtle_squid: nope, you can only resize from the bottom-left corner.
posted by equalpants at 8:01 AM on December 20, 2007


er, bottom-right
posted by equalpants at 8:02 AM on December 20, 2007


I have this problem (in tiger), but I solved it by scaling the doc itself so even when it's up it doesn't quite max out the window width. Try sysprefs->dock.
posted by butterstick at 8:24 AM on December 20, 2007


omnidrew, The dock in leopard looks really nice on the sides. They fixed all that before it was released.

Here are some examples.
posted by kpmcguire at 9:59 AM on December 20, 2007


You can lock your dock to the edge of the screen (defaults write com.apple.dock pinning start). Try locking it to the bottom-left edge and hiding it. That corner is the least-used, so it won't pop up unexpectedly. If it's so big it goes all the way across, it's too big. Get quicksilver.
posted by bonaldi at 10:14 AM on December 20, 2007 [1 favorite]


I'll suggest two things. First, make your dock much smaller....much smaller...but turn on just a bit of magnification (to help you 'hit' an app). With it smaller, you'll less likely get it to pop when you're trying to grab the edge.

Most macs now are widescreen, I move the dock to the left side...you can switch this almost on the fly by control clicking (or right clicking) on the divider between the applications and the documents on your dock.

I have almost nothing permanent in my dock (and I use launchbar or quicksilver...) but if you don't run either (and QS is free...), I'd suggest putting your Applications folder in your dock. Rather than have lots of apps in your dock, your Application folder permits a pop up of your apps (sorta like the start menu in windows).
posted by filmgeek at 8:51 PM on December 20, 2007


« Older Protecting an iPhone from thef...   |  Making DOS program get along w... Newer »
This thread is closed to new comments.