Join 3,562 readers in helping fund MetaFilter (Hide)


How to make a Remote Desktop Connection?
November 26, 2007 2:58 PM   Subscribe

Remote Desktop Connection across domains/workgroups. How can this work?

So, I have previously posted a Q about accessing my home Windows Workgroup from my work Domain Laptop... (see here)

deadmessenger's solution worked for me in this situation.

NOW...

I want to be able to Remote Desktop from my work XP Pro Laptop to my home Vista desktop (or other XP Pro machines at home.) Give the scenario outlined previously here, how do I connect to my home pc?

I've tried the IP address (192.168.0.2), and
I've tried \\home-server-name

Neither work... How do I do this? TIA!

Bonus Question: How can I do this across a Hamachi VPN? Does it make any difference?
posted by apark to Computers & Internet (6 answers total) 2 users marked this as a favorite
 
your "192.168..." ip address is internal to your home network, it is not usable beyond the router/dhcp box that made it up.
You need to setup a virtual server on your router, for the incomming port(s) that RDC uses, and you'll have to put in your actual IP address, not your internal one.
posted by nomisxid at 3:21 PM on November 26, 2007


they're all at home (or otherwise on the same network) and all the file sharing stuff works? did you turn on Remote Desktop? it's off by default. on XP, check by right-clicking on My Computer, then going to Properties and then the Remote tab therein. then connecting to the IP address or the computer name via the Remote Desktop client should work. this should also work similarly through Hamachi, but I'm not real familiar with that product specifically.
posted by mrg at 3:24 PM on November 26, 2007


nomisxid: But my laptop is also internal to my home network! The desktop I want to Remote to 192.168.0.2, but DHCP assigns my laptop a 192.168.0.3 address when I'm at home... Both the desktop & the laptop are internal to my home network in this scenario...

mrq: Yes, I can create a network share to the desktop from my laptop using the method in a previous post I referenced. I can also ping the desktop from the laptop...
posted by apark at 4:01 PM on November 26, 2007


Sounds like everything is working, just that you need to enable Remote Desktop before XP or Vista will let you connect.

Also, the version of Vista you have may not allow you to Remote Desktop to it.
posted by mphuie at 4:36 PM on November 26, 2007


Yes, the Vista version lameness. Vista Home Premium does not allow incoming Remote Desktop connections. Outgoing remote desktop usually works fine - but you can't Remote into it if that's the version of Vista on your desktop. Found this out myself this weekend. Vista Business & Ultimate OK, Home = No-Go.

Hamachi or some other flavor of VNC that plays well with Vista might work, but will take some messing with and might have some serious flaws (those UAC warnings might freeze you out).
posted by bartleby at 5:11 PM on November 26, 2007


Hah, I got it to work!

1. I have Vista Enterprise. As discussed above, there are some flavors of Vista where Remote Desktop does not work. You need to verify first that your flavor supports Remote Desktop Access.

2. I had to go to Computer->Properties->Remote Settings->Check "Allow connection from computers running..."

3. (HERE IS THE STEP I WAS MISSING) I had to go to the Control Panel->Security Center->Windows Firewall->Allow a program through Windows Firewall->Check the box next to "Remote Desktop"

4. Then I typed the IP address of the Vista box into the "Computer:" dialog box.

5. I typed "computer_name\user_name" (it's a backslash!)
in the "User Name" field. The "computer_name" is the actual name of the Vista computer I am connecting to. BTW, the user you are using should have been added as a Remote Desktop enabled user already in the target computer OR should be a member of the administrator group on that machine.

6. I typed the correct password for that account into the correct field.

7. Voila!
posted by apark at 10:37 PM on November 26, 2007


« Older Help me find books about insan...   |  I'm fed up with nearly getting... Newer »
This thread is closed to new comments.