Why isn't my wireless router working?
September 18, 2007 8:23 AM   Subscribe

My wireless router is not working, even though it keeps telling me that it has an excellent connection to my network...So, what did I do wrong?

(I'm extremely computer illiterate, so bear with my somewhat limited explanation)
We recently moved and had Rogers hi-speed cable internet set up. All is well with the modem and I can access the internet if my laptop is plugged directly into the modem. The problem is that we have two laptops and my roommate and I each need wireless internet in our rooms.

I have a D-Link DI-524 wireless router (version A-1). When I plug the modem into the router and enable my wireless connection, the wireless connection appears to be strong, but none of the websites ever complete loading. What's going on? Am I missing something? I followed all the instructions in the book, and after that I'm pretty much lost.

I currently have WPA password protection on my connection, but I don't think that would make a difference...?
I'm planning on calling D-Link tech support tonight, but any input here that would prevent me from being on hold for an hour would be appreciated.
posted by meesha to Computers & Internet (14 answers total) 4 users marked this as a favorite
 
Most routers have a web page for setup (perhaps at http://192.168.1.1) - you should check to see if it got an IP address from the modem.

Also, when you connected the modem to the router, did you power-cycle the modem? Some modems will only let one device (defined by it's MAC address - the unique ethernet hardware address) to connect. So, if you connected with your machine, then just moved the modem, it may not let your router get an IP address because the router's MAC address is different than your laptop's.
posted by nightwood at 8:27 AM on September 18, 2007


First, try the following:

Unplug the power from both your modem and your router. Leave it unplugged for about 10 seconds.

Connect the router and modem together with the network cable.

Power on the modem.

Power on the router.

Log in to the status page for your wireless router at something like:
http://192.168.1.1
http://192.168.2.1
http://192.168.3.1
...or similar. Consult your manual for the exact address.

Look for a Status page, and consult the WAN/Internet/ISP section to see if it obtained an IP address.
posted by odinsdream at 8:29 AM on September 18, 2007 [1 favorite]


1. Turn off WEP/WPA at first.
2. Ensure you can connect to router (d-link is usually 192.168.0.1)
3. Make sure you can browse. (Maybe the router isn't set up for cable, mine defaults to PPPoE)
4. Turn on WEP after you can connect to the router without it.
posted by i_am_a_Jedi at 8:30 AM on September 18, 2007


I agree with odinsdream, but you should really wait more like a minute to turn the modem back on, just to make sure it lost all mac addresses it had saved.
posted by Mach5 at 8:36 AM on September 18, 2007


You're sure that it's your own wireless network that your connecting to?
posted by Gratishades at 8:54 AM on September 18, 2007


Thanks.
I know I have an IP address from the modem (I went over that part with the Rogers tech support when I thought the modem wasn't working) but I'll definitely give these suggestions a try.
Quick question: Do I have to "clone the MAC address"? And should I select my IP as "static" or "dynamic"?
I should also have added that the router worked just fine with the same cable internet set-up at my previous apartment...so obviously I've missed a step in the set-up process.
My issue is that the connection says it's connected, but it's not...
posted by meesha at 8:58 AM on September 18, 2007


you should be able to plug in directly to the router. if you do that and it works, you know its a problem with the wireless settings. if that doesn't work, its a problem with the router and its connection to the modem.
posted by alkupe at 9:03 AM on September 18, 2007


most likely you want it set to dynamic. this option will dynamically handle the assignment of ip address. if you choose the static option it will require extra configuration for each computer connecting to the router.

i'm not sure if you need to clone your mac address, this differs from company to company and even location to location within the same company.

you can confirm if you need to clone your mac address by plugging your roommates computer directly into the modem. if they are unable to get online you need to. to be clear the mac you will want to clone is yours (i believe you said your computer can get online when plugged directly into the modem).
posted by phil at 9:35 AM on September 18, 2007


if you are using a windows machine you can find your mac address by doing the following.
1. select run from the start menu
2. type "cmd" into the field labeled Open: (minus the quotes)
3. select the OK button
4. type "ipconfig /all" and hit return (minus the quotes)

your mac address will be the field labeled "Physical Address"

note that this assumes you are using using windows 2k or later. if you are not please respond with the operating system you are using.
posted by phil at 9:42 AM on September 18, 2007


Thanks again.
I should have mentioned that I'm running Windows XP (no idea what edition) and that yes, I am definitely connecting to the network that I set up.
I'm going to try changing around some things tonight when I get home from work, and hopefully it'll work after that. Thanks for all your helpful responses, everyone.
posted by meesha at 10:13 AM on September 18, 2007


If it's anything like my local cable internet provider, they only allow registered MAC addresses, and only one per customer. What that means is that the physical network card in your PC was likely registered with your ISP. Your router has a different MAC address, which would not be registered. There are two options:

1. Use MAC cloning to make it look like the wireless router has the same address as the PC for the sake of the cable modem.
2. Let your ISP know that you are using a different device.

What is the IP address the wireless router is being assigned? I'd imagine it's a 10.x.x.x one, or a 192.x.x.x one, something that's local and non-routeable.
posted by mikeh at 10:39 AM on September 18, 2007


Ok, so if I clone my MAC address (for my computer), does that mean that I have to enter the same MAC address when I set up my roommate's laptop? Or should she just be able to access the wireless through the password-protected network?
posted by meesha at 10:45 AM on September 18, 2007


Your roommate will be able to get on via the wireless.

Think about it like an onion.
* The outermost layer that you can get is the modem, which I'm guessing you configured with a CD initially. At that point, it got trained to only accept traffic from your laptop's "fingerprint" (MAC address).
**The next layer of the onion is your router. You're going to be assigning your computer's fingerprint to the router so that everything it transmits (to the modem) appears to come from your PC.
***The innermost layer will be your two laptops. Your router will be spoofing one of their MAC addresses, but that doesn't matter, because your router will be configured, as it should, to allow traffic from any source that knows the wireless password.

Also, when you follow phil's advice, be sure you look at the Physical Address for the wired adapter. It will probably say Ethernet adapter Local Area Connection, and it shouldn't say "Wireless" anywhere.
posted by mysterious1der at 11:39 AM on September 18, 2007


Stop right now. Do not clone that mac and do other things you wont know to undo.You should really contact rogers and ask them for the proper settings such as:

1. IP address/subnet/gateway or if it can be done with DHCP
2. If they need to authenticate your router.

On the client side you can make sure your computer is set to get an IP automatically. You can also make sure you are connecting to the proper wireless network.
posted by damn dirty ape at 11:48 AM on September 18, 2007


« Older I'm a science nerd who's trans...   |  Please recommend some 9/11 lit... Newer »
This thread is closed to new comments.