Join 3,425 readers in helping fund MetaFilter (Hide)


Firefox freezes when downloading, help!
September 10, 2007 11:51 AM   Subscribe

I download a lot of images from the net. Using Firefox, the browser freezes while the file downloads. IE does not. I hate using IE. How do I make Firefox allow me to surf around while downloading?

I should add this is only the case when I use right click, "save as," and not when I click a prompted download. I think it happens for all files downloaded this way, not just images.
posted by yellowbinder to Computers & Internet (6 answers total)
 
I use DownThemAll, a Firefox addon, and have been very pleased with it.
posted by letahl at 12:03 PM on September 10, 2007


This is often related to a large or corrupted download history.
posted by Mitheral at 12:12 PM on September 10, 2007 [1 favorite]


Click the "clean up" button on your downloads list. Mine was really really slow one time, and it turns out it was that the list had too many entries.
posted by fvox13 at 1:08 PM on September 10, 2007


something else you can do is to disable the downloads window popping up when you save something. that way it will just download in the background and the size of your download history is mostly irrelevant until you actually open the window yourself.

i had a problem where i was downloading stuff off flickr, one file at a time but every time i hit "save image as" the browser would lock up for a few seconds before displaying the download window. multiply that times a hundred photos and that's a few minutes of my life gone.

once i disabled that, everything downloaded silently in the background without a hiccup.
posted by Ziggy Zaga at 1:40 PM on September 10, 2007


Seconding DownThemAll. You want to go with an extension here.
posted by papafrita at 1:56 PM on September 10, 2007


I clicked the "clean up" button on the download page, and that caused a massive freeze-up, unsurprisingly. I eventually killed Firefox and removed download.rdf from (since this is Windows): c:\documents and settings\\Application data\Mozilla\Firefox\Profiles\.default\. That worked.
posted by of strange foe at 2:08 PM on September 10, 2007


« Older PHP/TransactionFilter: Designi...   |  Due to safety concerns, my fam... Newer »
This thread is closed to new comments.