Join 3,497 readers in helping fund MetaFilter (Hide)


How to get a Mac mini to reconnect to a wireless network automatically?
July 25, 2007 5:26 AM   Subscribe

I have an Intel Mac mini using a wireless WPA connection to connect to a router which is connected to the Internet. The wireless connectivity works relatively well. However, once it gets disconnected, even if the signal may be lost just temporarily, Mac OS just "gives up" at trying to reconnect. How do I make Mac OS try and try again to reconnect to the wireless network once it has been disconnected?

I don't know if there are any commands I can use in the Terminal to connect to a wireless network. If there are, I'm thinking I can probably set up a simple cronjob to check the connectivity and attempt to reconnect if the connection was dropped.

Or maybe there is already a 3rd-party solution to accomplish this? Hopefully, it's freeware.

Any ideas would be appreciated. Thanks!
posted by remi to Computers & Internet (6 answers total) 1 user marked this as a favorite
 
Did you install the 10.4.10 update? There's plenty of evidence it's causing major WiFi problems. The only work around for now is to not use WiFi.
posted by tommasz at 5:36 AM on July 25, 2007


Crap. I probably did. Thank you auto updates!

Unfortunately, going wired is not an option for me.

If I can reconnect manually using a command in the Terminal, that will have to do for now!
posted by remi at 5:41 AM on July 25, 2007


Right now on macfixit.com there are several reports and advice in dealing with the gremlins in 10.4.10.

It is running fine on both of my macs so I haven't followed the instructions to rolling back to 10.4.9 but that might get you back to where you want to be.
posted by birdherder at 6:09 AM on July 25, 2007


This is what I did for my macbook:
System prefs -> network -> show airport -> airport tab
Set preferred networks to only include my home network and work networks (i.e. erase any neighbors' networks you may have connected to while at home).
Now, under the same tab, go to options and select at the top "If no pref'd networks are found keep looking for recent networks". That does the trick maybe 8/10 times for me.
posted by monkeymadness at 7:32 AM on July 25, 2007


What monkeymadness said. OS X should automatically keep trying to connect to the networks in your "preferred networks" list. It doesn't "just give up" as far as I can tell, but it might take a while to reconnect sometimes, even without the problematic 10.4.10. One trick I use with my laptop is putting it to sleep for about 1-2 seconds, then waking it up again. That seems to force it to try again right away. Annoying, I know.
posted by edjusted at 12:34 PM on July 25, 2007


May I piggyback a bit? I'm on 10.3.9 and I find often when waking up from sleep my ibook won't reconnect to my wireless network. I have to turn off then turn on Airport to get it to try. Lately I've noticed this happening when I boot up as well.
posted by loiseau at 10:11 PM on July 25, 2007


« Older Do I call him? Probably should...   |  we have two recalcitrant boys.... Newer »
This thread is closed to new comments.