Skip

How do I get gmail out of HTML back to standard version?
July 22, 2007 9:58 PM   Subscribe

What did I just do to my gmail? I can't get it back out of the HTML into the standard version.

I was trying to make firefox use gmail to email from a link in a webpage like I had before (anyone know how to make this happen = bonus points*). I had recently installed microsoft office 2007 (and I think Outlook screwed everything up--I hate how Microsoft assumes it's program is the best in the world and everyone uses nothing but Outlook. I HATE OUTLOOK!). Sorry for the rant. But the only thing I did was remove a few addons (Better Gmail from Lifehacker) and some others that had no relevance to gmail (can't remember them specifically).

At the top of the webpage, it says "you are viewing in basic HTML. Click here to switch to standard viewing" or something like that. But when I click the link, it does nothing! I've tried reinstalling firefox, and the addon/extensions but nothing has seemed to work yet.

Anyone know what I did?

PS, the gmail skins extension also isn't working either.

Please help me get my gmail fixed! (and fix!)
posted by uncballzer to Computers & Internet (9 answers total)
 
Try looking at it with Internet Explorer or some other browser, so you can eliminate Firefox weirdness as the cause
posted by delmoi at 10:26 PM on July 22, 2007


Wow, that standard view sure is weird. It doesn't use cookies, rather it uses specially made URLs on all the links. All you have to do is go to this URL to get to normal Gmail. If it goes back to standard, you probably have some weird glitch with firefox.
posted by delmoi at 10:29 PM on July 22, 2007


I was trying to make firefox use gmail to email from a link in a webpage like I had before...

This happened to me too, but I'm using a Mac, so it reverted to Mail, which is a total pain in the ass. Sorry I can't offer a solution, but maybe it's something wonky with Firefox and not with Outlook.
posted by solipsophistocracy at 10:53 PM on July 22, 2007


Here's how to get gmail to be the default "mailto:" protocol handler.

On a Mac, Google Notifier adds this capability, regardless of browser. It's probably the same for the Windows version.
posted by O9scar at 11:16 PM on July 22, 2007


Any chance you were using the UserAgent switcher extension and left it set for IE?
posted by jbroome at 11:25 PM on July 22, 2007


This happened to me once (Firefox, Ubuntu). Drove me nuts until I realized that I still had the User Agent Switcher extension turned on, making Firefox claim to be Internet Explorer (or was it Googlebot? Can't recall).

Try visiting one of the many sites that will tell you what your current user agent string is (here's one) and make sure Firefox is identifying itself correctly.

If it isn't, and you don't have the User Agent Switcher extension installed, put about:config in the address bar to get to the Firefox setting page, type agent into the Filter: box, then right-click on any of the general.useragent.xxx settings that show up in bold and select Reset from the context menu to put them back to what they should be.

If you still have no joy, try again after making a fresh Firefox profile. Note that uninstalling and reinstalling Firefox does not create a fresh profile.

If the fresh profile fixes the issue, you can transfer all your bookmarks from your old broken profile into the fresh one by copying bookmarks.html from the old profile folder to the new one.
posted by flabdablet at 11:38 PM on July 22, 2007


I'll second (third?) jbroome and flabdablet's suggestion, as I've done this personally. I was confused for at least a week and thought of posting the same question.

*shakes fist at sites that are 'incompatible' with major browsers*
posted by chipb at 12:53 AM on July 23, 2007


either --

(a) type http://mail.google.com/mail in the address bar manually (it will redirect you to your mailbox so you don't have to re-log-in again), or

(b) scroll to the very very bottom and in tiny print there is "switch view" and pick standard.
posted by vanoakenfold at 7:47 AM on July 23, 2007


GMail will force you into the HTML mode if it detects your browser isn't up to the full mode.

Check that:
1. You aren't spoofing your user-agent so that it thinks your browser isn't up to it.
2. Javascript is on
posted by bonaldi at 8:25 AM on July 23, 2007


« Older Can you take cough drops into ...   |  I cut my foot pretty severely ... Newer »
This thread is closed to new comments.


Post