Join 3,512 readers in helping fund MetaFilter (Hide)


How to get MT to see my stylesheet?
July 21, 2007 3:47 AM   Subscribe

Movable Type stylesheet issue: MT3.2 won't link to my stylesheet. And I can't find my problem covered anywhere (in forums or in MT's documentation.

Nothing had been changed or fiddled with, except that I added a URL to my index page and rebuilt it, something I've done a million times.

My blog functions as my writing portfolio -- it's where I post my work and a huge reason I get work.
posted by mdiskin to Computers & Internet (11 answers total)
 
Can you post your code as an example?
posted by sephira at 7:33 AM on July 21, 2007


Have you viewed source and looked at the link to the stylesheet to see if the link is broken or just not there at all?

Post a link to the blog and I will take a look, if you'd like. MT/Typepad blogs are one of my specialties. :)
posted by miss tea at 8:41 AM on July 21, 2007


yeah, post a link.
posted by fishfucker at 10:05 AM on July 21, 2007


The code looks okay, and it's referencing the stylesheet, but it's just not seeing it somehow.

Link: melissadiskin.com
posted by mdiskin at 10:44 AM on July 21, 2007


This is the link in your blog to the style sheet.

Not right, it should be
http://melissadiskin.com/styles-site.css
Movable type uses a token,
< $mtblogurl$>
, to generate the stylesheet link. So there's your problem, MT is using the wrong URL. Notice that your links all start with
http://p8.hostingprod.com/@melissadiskin.com
which I assume was not the case before?

It's possible/probable your webhost/registrar has changed the way it handles mapping. Also doublecheck your MT settings, go to blog -- publishing settings and double-check the site URL and site path fields.

As a quick fix while you're dealing with that piece if you want it to look better you can hardcode a link to your style sheet into the templates, like link href="http://melissadiskin.com/styles-site.css" rel="stylesheet" type="text/css" (except with brackets of course).
posted by miss tea at 12:12 PM on July 21, 2007


Hmm. I hardcoded the link into my templates and also changed the pub settings (switching site URL) and nothing happened.
posted by mdiskin at 12:57 PM on July 21, 2007


(and of course I rebuilt all my files)
posted by mdiskin at 12:58 PM on July 21, 2007


there's an extra < at the beginning of the reference. right now it is:br>
href="< http:br>
you should change to href="http:
posted by miss tea at 1:34 PM on July 21, 2007


damn sorry, it got mangled. but the last bit is right, check the syntax...
posted by miss tea at 1:36 PM on July 21, 2007


thanks. I'm blind.

really: xoxoxo to miss tea....
posted by mdiskin at 3:55 PM on July 21, 2007


glad to help :)
posted by miss tea at 6:15 AM on July 22, 2007


« Older Which microphone should I buy ...   |  Getting married next week and ... Newer »
This thread is closed to new comments.