Join 3,512 readers in helping fund MetaFilter (Hide)

Tags:

Gmail & iPhone Problem
July 3, 2007 6:14 PM   Subscribe

Every time I send an email via gmail on my iPhone, I get a duplicate of the email in my in box.

I'm having a problem using gmail on my iPhone. Every time I send a message, it sends perfectly and then gets placed in my sent mail folder on the phone, just like it should. But it *also* shows up in my in box as new mail. It's driving me crazy.

Heres a link to a Mac forum where people (including me) have been discussing the problem a little bit, but nobody seems to know why this duplicate email business is happening: http://forums.macrumors.com/showthread.php?p=3868019#post3868019

I've tried all the suggestions mentioned in that thread about creating filters, but nothing so far has solved the problem.

(The CC a copy of your email to yourself option on the iPhone is turned off.)

Help!
posted by buriedpaul to Technology (23 answers total) 2 users marked this as a favorite
 
It's not an iPhone specific problem -- I had the same problem when would use gMail's web access from work, but gMail's POP3 into my Mail programme while at home. Every email I sent from the webpage would then appear as a new message in my inbox at home.

The only way around it is to create a filter in your mail (on your comp's mail programme, not your phone) that basically says "if the message is from buriedpaul@gmail.com, mark as "read" and move to sent messages folder".

This did the trick for me.
posted by modernnomad at 6:20 PM on July 3, 2007


Thanks modernnomad. I don't use a mail program at all on my computer -- I access gmail exclusively through the web. The only filtering options that gamil offers are: Skip the Inbox (Archive it), Star it, Apply the label:, Forward it to:, Delete it.

I've tried setting up a Skip the Inbox filter, but that doesn't solve the problem. When I set up a Delete it filter, I get an error message every time I try to send gmail (via the web) on my computer.
posted by buriedpaul at 6:32 PM on July 3, 2007


Had the same issue with my BlackBerry, the above comment fixed it for me too. Filter your own email address to a Sent or From Me label.
posted by heavenstobetsy at 6:32 PM on July 3, 2007


To clarify, you want to choose, Skip the Inbox (Archive), Apply the Label. If you want them deleted, just choose Delete It, not Skip the Inbox AND Delete It.
posted by heavenstobetsy at 6:33 PM on July 3, 2007


Even when I filter messages from my account to Skip the Inbox, they still show up as new messages on my iPhone. And filtering them to delete gives me problems when I try to send mail from my computer.
posted by buriedpaul at 6:36 PM on July 3, 2007


Sorry, didn't really read your reply. Skipping the Inbox and Applying a Label worked for me, anyway!
posted by heavenstobetsy at 6:40 PM on July 3, 2007


I post a suggestion from a friend:

You just need to fix the following on the iphone:

Settings -> Mail -> [your gmail account] -> Advanced -> turn off "Recent Mode."
posted by rdn at 6:40 PM on July 3, 2007


See if it is possible for you to apply filters on the iPhone. Not having one, I had no idea. Possible with a BlackBerry.
posted by heavenstobetsy at 6:41 PM on July 3, 2007


From Gmail help: Why do messages I send appear in my mail client's inbox?:
Once you've enabled POP access, Gmail will download all messages in your account, except for spam and trash. If your mail client isn't configured to categorize your mail, all of your Gmail messages will appear in your mail client's inbox. You may want to contact your mail client's customer service department for instructions on how to categorize downloaded messages.
posted by kathryn at 7:23 PM on July 3, 2007


I believe using the recent: command for pop3 stopped this problem when I encountered it in the past.
posted by striker at 7:34 PM on July 3, 2007


Read what the OP said, all you POP3 people!
posted by croutonsupafreak at 8:07 PM on July 3, 2007


Just another note that this is a Gmail-specific problem, not an iPhone-specific problem. I have had this happen anytime interface with Gmail from any strange place, like via a cell phone or POP client.

Uh, what's the loose end at this point, all you crouton people?
posted by scarabic at 12:12 AM on July 4, 2007


This has been driving me nuts with my Blackberry. I just tried the filter thing and it didn't work. Any other suggestions?
posted by CunningLinguist at 1:07 PM on July 4, 2007 [1 favorite]


Gmail forum discussion/complaint thread. No solutions yet besides the filter thing that doesn't work for me.
posted by CunningLinguist at 5:27 PM on July 4, 2007


I finally fixed this problem by setting up an AOL email address and forwarding my gmail to it. Configuring the SMTP server to my Gmail account makes the AOL address invisible when I reply to emails on my phone (so they look like they come directly from my Gmail account). Here's a walk through, from forums at macrumors.com:

So on my iPhone I went to set up a new email account. I clicked "Other" and named it GMail/IMAP and set it to IMAP.

Then I fill in the name, and email address for the IMAP server; I fill in the username and password for the IMAP server and the mail server is for the IMAP server.

The SMTP server is smtp.gmail.com; and the SMTP username and password is your GMail ID@gmail.com and GMail password.

In GMail I have two settings. The first is to forward all mail to the IMAP email address. The second is to take all messages from ME (myGMailid@gmail.com) and skip the inbox and go straight to archive. This last setting keeps them from be forwarded back to my IMAP address.

I have duplicated these exact settings for mail.app and turned off my GMail pop account. When I send a message through the IMAP "front end" the recipients think I have sent it straight from GMail. I have even checked the long headers for any mention of my IMAP email address and couldn't find any. To everyone else it looks like I am still using GMail. I get the benefits of IMAP interplay between my main machine and iPhone and when I am away from my iPhone or main machine (unlikely) I can access all my mail via the GMail web interface.

The iPhone really requires IMAP functionality. When using straight GMail (even with the Recent functionality turned on) when you are away from your computer and using your iPhone you may read a bunch of messages, but then when you return, your computer says they are all unread. Additionally every time you send a message from your iPhone, GMail bounces a copy back into your iPhone inbox so ten minutes after you send a message you think you have a reply only to see its your same damn message that you sent. I love GMail but it only works well if you stick solely to their web interface or have only one POP Client that you download too. Previously that is what I did (download only to my macbook with mail.app) but the iPhone changed that for me.

I have only used this for a day now, so I haven't fully tested it out, but the Sent Mail bounce-back of GMail was driving me crazy on my iPhone. And using any email web interface on mobileSafari is just lame compared to the Mail client (which is the worst app on the iPhone, IMHO).

Hope this helps.

The full thread is here.
posted by buriedpaul at 1:32 PM on July 7, 2007


Ugh... Really?

The best options people(and Google) have come up with is forwarding all Gmail, creating a Send As Adress account or deleting all sent mail, resorting to losing a retaining copy even in your Sent Mail folder?
posted by blastrid at 1:05 AM on July 9, 2007


Settings -> Mail -> [your gmail account] -> Advanced -> turn off "Recent Mode."
That worked for me. Thanks!
posted by d723 at 10:49 PM on July 10, 2007


"Recent mode will fetch the last 30 days of messages, even if they have already been fetched by another client. "
posted by d723 at 10:53 PM on July 10, 2007


I tried disabling "recent mode" yesterday and suddenly found my iPhone was re-filling with EVERY E-MAIL I'VE EVER SENT OR RECEIVED THROUGH GMAIL. And I've been using it as my primary e-mail client since 2004. So turning off recent mode is a terrible, terrible idea if you have a lot of e-mail in your Gmail inbox. I could try moving it all to the Archive, but it seems that Gmail downloads those when you're using POP anyway, since they're not spam or trash.

This is starting to get infuriating, and it's making Gmail almost unusable on my phone. I wish I'd just dealt with the annoyance of receiving a copy of all my sent e-mails, instead of trying to fix it.
posted by logovisual at 9:30 AM on July 13, 2007


@logovisual, you can prevent that from happening by editing your pop/forwarding settings in the gmail web client.

Settings -> Forwarding & POP ->
[x] Enable POP only for mail that arrives from now on
posted by brock at 7:58 PM on July 20, 2007


I rigged up a IMAP/gmail hybrid system for my iphone email that I detailed in here
posted by headlouse at 8:48 PM on July 23, 2007


I wish I'd just dealt with the annoyance of receiving a copy of all my sent e-mails, instead of trying to fix it.

Yeah, I've just resigned myself to deleting the copies when they land on my berry. In the end, it's less hassle.
posted by CunningLinguist at 8:49 AM on July 24, 2007


If anybody's still looking for a solution to this problem (I'm on 1.1.3 now, so this might not have been relevant when this thread was active) here's what I did:

Go to Settings > Mail > click on the Gmail account you are having trouble with > Advanced > Change "Sent Mailbox" to "Sent Mail" and "Deleted Mailbox" to "Trash"
posted by raisehelldrinkbeer at 8:29 PM on February 7, 2008


« Older What is the name of the simple...   |  I am a grad student in a compu... Newer »
This thread is closed to new comments.