Join 3,382 readers in helping fund MetaFilter (Hide)


Using Firefox with Yahoo mail: How do I make "clickable" a url that is pasted into the body of an email?
May 19, 2007 9:59 AM   Subscribe

Using Firefox with Yahoo mail: How do I make "clickable" a url that is pasted into the body of an email?

This happens when I use Firefox (1.5.0.11) to send urls in emails via Yahoo web based email: upon pasting a url link into the body of an email, the url doesn't appear highlighted/underlined. The problem: when sent, the recipient cannot click on the link to open the page which the url refers to, but rather has to manually copy the url and paste the link into the address bar. This doesn't happen when I use IE.

Why does this happen in Firefox and not IE? Is there a Firefox plug in that would make these pasted urls "clickable"?. Thanks.
posted by bbranden1 to Computers & Internet (6 answers total) 1 user marked this as a favorite
 
Are you composing your emails as plain text? If you change your (yahoo) mail options to compose email as html, then you can just put in some html:
<a href=http://link here>underlined clickable text</a>

Although, I've noticed lately that yahoo started to display a little tiny popup that will ask if I want to follow the url in the email people send me (there are also pop-ups for yahoo maps over place names). I've no idea why your browser should affect this at all. Have you tried sending yourself emails (using both browsers) and confirming that they are different when using different browsers to compose the email?
posted by philomathoholic at 11:20 AM on May 19, 2007


You mean when you enter the http:// it still doesn't become a link?

In that case I would be inclined to wonder if it's some kind of anti-phishing measure. Do you have security settings to alter?
posted by loiseau at 12:26 PM on May 19, 2007


Solved.

I'm not sure whether the emails are plain text: I do have a bar above the box for text entry; it has formatting options.

In that formatting bar I've just noticed an icon of a globe under a chain link. If I highlight the url, then click the globe icon, then paste that same url into to the new box (that pops up in response to clicking on the icon) and then hit enter, the url in the body of the email suddenly becomes underlined and, when sent, is "clickable". So that seems to be the solution.

re: loiseau's question: prior to discovering the globe icon, ensuring that http:// was in front of the url did not cause it to become clickable in Firefox. As to anti-phising settings, there are none that I know of.

This maneuver of using the globe icon to make clickable urls, even ones preceded by http://, seems necessary only in Firefox. IE creates the clickability immediately upon pasting the url and hitting enter, even if http:// does not precede the url (as long as www does precede, of course.)

Thank you, philomatholic and loiseau, for your efforts to help me solve this problem.
BB
posted by bbranden1 at 1:04 PM on May 19, 2007


Please also see this article that was linked from another recent AskMe question. In short, it recommends the form:

<URL http://linkyouwant.com/page >

This seems to work in e-mail; I haven't tried it in web e-mail, but it _should_ work. Want to give it a try & let us know?

This has the added benefit of assuring that long links won't be broken across lines, and doesn't require that you use HTML in your message (which may be what that link thingie does, or not, I don't know) -- HTML won't work for everyone reading e-mail.
posted by amtho at 8:08 AM on May 20, 2007


Thanks, amtho. A clever thought, but it doesn't seem to work, at least on the Firefox/Yahoo combination in my computer.
BB
posted by bbranden1 at 8:39 AM on May 20, 2007


Maybe because the article antho links to actually recommends the form <URL: http://linkyouwant.com/page >, instead of his version, which lacks the colon after URL?
posted by harkin banks at 5:58 PM on May 21, 2007


« Older My friend and I would like to ...   |  My employer gives out bonuses ... Newer »
This thread is closed to new comments.