Skip

Can't install any Greasemonkey scripts
April 19, 2007 8:52 AM   Subscribe

Why wont Greasemonkey let me install anything?

For the first time ever I actually want to use a greasemonkey script (to prettify my gmail).

I've installed greasemonkey but when I click the Install button when attempting to load the gmail script it doesn't do anything. neither does using the Manage Scripts window.

I'm running the latest version of Portable Firefox on my work PC, but I've also tried installing it at home with no success.

I should note that the Profile directory for the Portable Firefox is copied over from my Profile at home. So if there is a problem with my Profile it may be what's stopping it working on both.
posted by lemonfridge to Computers & Internet (9 answers total) 1 user marked this as a favorite
 
Greasemonkey uses javascript I think - do you have it disabled?
posted by Happy Dave at 9:39 AM on April 19, 2007


The script works - I just installed it. Is Portable Firefox blocking downloads from userscripts.org?
posted by corvine at 9:46 AM on April 19, 2007


Ive enabled all the javascript options. Still no luck.
posted by lemonfridge at 9:47 AM on April 19, 2007


corvine, no scripts will install. None at all.
posted by lemonfridge at 9:47 AM on April 19, 2007


Try uninstalling greasemonkey and grabbing a fresh copy from the Mozilla website.
posted by Happy Dave at 9:52 AM on April 19, 2007


Create a new profile, run Firefox with it. It'll start with no extra extensions. Add greasemonkey. Restart. Then see if it'll work.
posted by Zed_Lopez at 9:55 AM on April 19, 2007


Zed_Lopez thank you :)

I created a new profile, installed Greasemonkey and the Userscript, and then copied the gm_scripts folder from one profile to the other and it's working. It'll do for me anyway :)
posted by lemonfridge at 10:05 AM on April 19, 2007


I know you have already solved it, but for the record, I had this problem on Mac and was able to solve it by running these commands in the terminal:
# cd ~/Library/"Application Support"/firefox/profiles/[your profile]
# mkdir gm_scripts
# touch gm_scripts/config.xml
More info here.
posted by JamesToast at 10:11 AM on April 19, 2007


I also had a similar problem - GM's first install screwed up and left monkey crap in my config which prevented me from installing it again. Visiting about:config and deleting all entries related to GM (searching for "greasemonkey" was quickest) did the trick.
posted by blag at 5:01 PM on April 19, 2007


« Older Recommendations needed for hea...   |  Blogger is polluting my websta... Newer »
This thread is closed to new comments.


Post