Join 3,497 readers in helping fund MetaFilter (Hide)

Tags:

Intrusive device
April 15, 2007 7:05 AM   Subscribe

How do I add or change something in Windows' "what do you want to do?" list for a plugged-in device?

Whenever I plug in my USB flash drive, Windows XP presents an annoying dialog box tellling me that the device contains more than one type of file, and asking me what I want it to do. I want it not to open in the first place. The next best thing would be to open the drive in my favorite Explorer substitute, xplorer2. The dialog offers "open in Explorer" as an option. There must be a registry entry somewhere where this can be modified. Do you know where it is?
posted by yclipse to Computers & Internet (16 answers total) 5 users marked this as a favorite
 
Is there no "Take no action" option? If so, this may be useful? Otherwise, the normal way to do this is to select "take no action" and "do this every time" when prompted... And if that doesn't work, the other normal way is to open My Computer, right click on the device > properties, and adjust using the AutoPlay tab.
posted by anaelith at 7:22 AM on April 15, 2007 [1 favorite]


i didn't double check it and i'm not totally sure it will work, but what about creating a text file called autorun.inf
containing:

[autorun]


and thats it, then place it in the root of the flash drive.
and then nothing will autorun?
just a quick guess.
posted by RobertDigital at 7:42 AM on April 15, 2007


The same thing happens to me, and it's annoying as hell. On some computers I get an option to "do this every time," but not on my home computer. Anyway, on my work computer it seems to forget every few days that I've told it to do the same thing every time.
posted by goatdog at 7:47 AM on April 15, 2007


Microsoft instructions on AutoRun CDs.
posted by Mitheral at 8:17 AM on April 15, 2007


In my opinion, the easiest way to manage this is to download and install TweakUI, a Microsoft Powertoy that centralizes control of all of your drives and lets you edit or create autoplay handlers.

There are a couple of other options, the first of which is to insert the drive, right click on it in explorer and choose "Properties" then select the "Autoplay" tab and modify as you like. (I am not certain, but I believe this option will only work consistently as long as the computer assigns the same drive letter to the device, so if you are frequently attaching/detaching drives, then this probably isn't a good solution for you.)

The other way is go to the Start menu, select "Run", and type "gpedit.msc" then select Computer Configuration > Administrative Templates > System > Turn Off Autoplay.
posted by camcgee at 8:44 AM on April 15, 2007


camcgee: TweakUI won't let you edit autoplay unless you run it as Admin. (In fact, it won't even mention that it can DO such a thing unless you run it as Admin.)

(And in fact, the more I think about it, the more likely it seems that some of the problems above are caused by not being logged in as Admin at some point--way to shoot security in the foot, Windows.)
posted by anaelith at 9:51 AM on April 15, 2007


TweakUI won't let you edit autoplay unless you run it as Admin.

I do not need to be logged in under the administrator user account to do any of the above. I do it with a normal user account that has admin privileges -- this is XP Pro, though, and XP Home might have greater restrictions.
posted by camcgee at 10:42 AM on April 15, 2007


RobertDigital: I know that won't work, because on my flash drive I have an autoplay file that changes the icon shown in explorer, and that dialog still comes up.
posted by philomathoholic at 11:29 AM on April 15, 2007


This has been annoying me too... and anaelith's solution works perfectly. Thank you!
posted by Acey at 2:51 PM on April 15, 2007


None of the above works, including TweakUI and the AutoFix. And although there is a Take no Action option, there is no option to "do this every time".
posted by yclipse at 4:06 PM on April 15, 2007


I do not need to be logged in under the administrator user account to do any of the above. I do it with a normal user account that has admin privileges
Er... a rose by any other name..? (If you're logged in to an account that has admin privileges, even if it's not actually named administrator, then you've still got all of the security problems then you would have if you were actually logged in to an account named administrator with admin privileges. I understand that many people don't care about the problems, which is fine by me, as long as no one thinks they magically go away if you rename the account.)

yclipse, have you tried My Computer, right click > properties, AutoPlay tab? If you "select an action to perform" and select take no action, it should take no action every time--but you do need to make sure that the drive letter (that you right clicked on) and the type of files (selected from the drop down) match up to your USB stick.
posted by anaelith at 6:14 PM on April 15, 2007


Can I piggy back this and ask how the same thing, but for macs? Or more specifically, how do I stop iPhoto from opening when I plug in my camera?
posted by oxford blue at 11:39 PM on April 15, 2007


Turning things off with the Autoplay tab takes a good long while, because you have to do a little dance. The first step is selecting a content type (music, pictures, mixed content...) with one of the little tabs; then you click Take No Action; then click Apply; then select a different content type; rinse and repeat until you've worked through the whole lot.

Setting "take no action" on the "Music CD" content type, which IIRC is the default, will have no effect if Windows determines that the drive in question contains "mixed content", for example. You have to kill them all individually.
posted by flabdablet at 12:48 AM on April 16, 2007


Googling autoplay registry led me here, among other places; should be possible to generalize from that if you want to create your own custom handlers. Edit registry at own risk, make backups first, yada yada.
posted by flabdablet at 12:54 AM on April 16, 2007


oxford blue, googling iphoto autostart "os x" got me this. Any use to you?

I swear, if anybody ever finds out how easy Google makes being a technician, I'll be out of a job.
posted by flabdablet at 1:01 AM on April 16, 2007 [1 favorite]


You're a good man charlie brown. And I won't even be all bashful and pretend I searched myself, or lost my limbs in a tragic swimming pool accident (one minute the ladder was there. The next? Gone!) That's how deep our relationship is–pure honesty.
posted by oxford blue at 5:17 AM on April 16, 2007


« Older Canadian tax question: After s...   |  Where to purchase indian cookw... Newer »
This thread is closed to new comments.