Join 3,553 readers in helping fund MetaFilter (Hide)


Help me figure out why my DVDs won't play on my computer.
March 3, 2007 7:39 PM   Subscribe

Why won't these DVDs play on my computer? For some reason, a few new DVDs I've tried to watch on my computer recently won't play properly. They won't play at all on my usual DVD program, and when I use VLC (my usual last resort) they play without any dialogue. Because older DVDs still work fine, I figure it's some fancy pants new copy protection scheme. Why aren't these DVDs playing properly, and how can I force them to?

Some sound still comes through (mostly music and background noise), but dialogue comes through about one line out of twenty. So far, A Knight's Tale works fine, and A History of Violence and The Devil Wears Prada have the no dialogue problem on VLC.

When I try to play either of these DVDs in Windows Media Player or the standalone DVD player program I use, they won't play at all, giving wierd error messages or saying that the disc isn't a format recognized by Windows.

Oh yeah, this is a Windows machine. I haven't installed any new software since this problem arose. I haven't had any other audio problems. I'll try to answer any other questions that might help diagnose the problem.

Mostly I just want to know how to play these DVDs on my computer. I'm also interested in what the heck is happening though, because none of my googling has found anyone with a similar complaint (which makes me doubt my copy protection scheme theory).
posted by MadamM to Technology (21 answers total) 2 users marked this as a favorite
 
This isn't a problem with region settings, is it?
posted by Dasein at 7:51 PM on March 3, 2007


I'm in the US playing Region 1 DVDs, so I don't think so.
posted by MadamM at 7:56 PM on March 3, 2007


To test the Windows operating system installation, you might install and run Linux (perhaps on a flash disk), to see if you can play the DVD under that setup.
posted by Blazecock Pileon at 7:58 PM on March 3, 2007


Erm... installing and running Linux is a bit out of my technological experience range.

btw, is babysitting my question this way bad form? I'm checking this often because I'd really like to watch these DVDs tonight and it seems silly not to answer questions addressed to me, but I don't know if having every other answer be from the OP is considered wrong in any way...
posted by MadamM at 8:02 PM on March 3, 2007


Well, the easiest way to remove your hardware as a possible source of the problem is to test under another operating system, or remove the DVD drive entirely and put it into another computer.

If you can't install Linux, you might try creating a Bart PE disc and see if you can test your DVD drive under that.

Or physically remove the drive and place it into another computer, testing movie playback on that system.
posted by Blazecock Pileon at 8:11 PM on March 3, 2007


None of the other computers in my house has a functioning DVD drive, so that idea won't work. And taking out this computer's DVD drive and putting it into another machine is again waay beyond my technical expertise.
posted by MadamM at 8:18 PM on March 3, 2007


check your audio settings? maybe it thinks you're using 5.1 and it's confused. (a lot of the time, the rear speakers are doing background noise and/or music.)
posted by mrg at 8:18 PM on March 3, 2007


yeah, it sounds like when you play in VLC, it's either not playing the center channel or only playing the surround channels.

try Media Player Classic. I've found it works a bit better than VLC for playing DVDs.
posted by neckro23 at 8:23 PM on March 3, 2007


Hm, I found one report of fixing a similar problem by unplugging everything (after, of course, powering down your computer and switching off your power strip, etc.) and plugging everything back in. Also a google search showing similar problems which you can read through.

My other thought is that if you have WindowsUpdate set to automatic, that's an easy way to pick up unexpectedly new copy protection, and would explain why WMP fails.
posted by anaelith at 8:58 PM on March 3, 2007


Hmm... I thought the audio thing might pan out, because I was using headphones plugged into my surround sound speakers, but playing the audio through my speakers didn't fix the problem. And an audio channel problem doesn't explain why the DVDs won't play in my normal DVD program.

Incidentally, playing A History of Violence to check out the audio thing reminded me of something: that DVD is one of those with the annoying InterActual player bundled with it. I installed it (in desperation) when I was trying to watch that movie last week. It still wouldn't play the DVD, the program that came on the DVD to watch it on the computer! I think it had some error message about an unrecognized file format or something like that.
posted by MadamM at 8:59 PM on March 3, 2007


Turning everything off/on didn't help.
posted by MadamM at 9:33 PM on March 3, 2007


I've had a similar problem before (and sorry if this has already been mentioned) where the media player was playing a surround sound track when my system was not set up for it. You might try looking around for the place in your program where you pick the track and setting it to something basic like stereo.

Have you tried playing an old dvd in your system since this problem started? If it still plays correctly, that would seem to confirm that it is in fact a problem with new dvds and not your computer.

Especially in something like this, I think it's pretty useful for you to hang out here and answer questions so we can eliminate possible solutions.
posted by !Jim at 10:13 PM on March 3, 2007


I don' have any direct solution to suggest, but VLC's preferences have about 100 different options under Audio if you tick "Advanced", so I'd be messing with those if it were me.

Also some DVDs allow you to change your audio setup as part of their interface, see if that's possible. If you can change audio from 5.1 to stereo that might fix it.
posted by AmbroseChapel at 10:16 PM on March 3, 2007


NOT turning on and off, but actually unplugging and replugging everything (i.e. cord between computer and speakers). I believe the idea is that the connection between computer and speakers may be partially unplugged, resulting in a dropped channel.
posted by anaelith at 10:17 PM on March 3, 2007


Check your manufacturer's website to see if your DVD drive has some updated firmware. I flashed the firmware in my DVD burner when I was unable to burn newer dvds. Perhaps flashing the firmware would help you read newer dvds?
posted by fvox13 at 11:33 PM on March 3, 2007


If you think its copy protection, install SlySoft's AnyDVD. Works great for playing and ripping copy protected DVDs.
posted by mphuie at 11:52 PM on March 3, 2007


It definitely sounds like you're playing surround sound through a stereo system, so check all the relevant settings (DVD playing software, sound card config).

I once bought a DVD player that defaulted to 5.1. I was sat watching an arty film for 10 minutes before realising the sound wasn't that arty and I should be hearing the people talking, not just the running water in the background.
posted by malevolent at 1:02 AM on March 4, 2007


MadamM writes "Erm... installing and running Linux is a bit out of my technological experience range."

Puppy Linux will boot from a cd, and it includes a DVD player. It's pretty easy and it'll help you figure out whether it's a hardware or software problem.
posted by concrete at 9:18 PM on March 4, 2007


I've had the same problem with a new DVD not playing on my computer (though others work just fine). I tried WMP and PowerDVD, same results. I figured it was some newfangled crap they put on there, I guess possibly (probably?) related to a copy protection scheme.

In my case, it turned out that the movie was hideous and my computer was doing me a favor. (It was Under the Tuscan Sun if you must know). I will never get those minutes of my life back.
posted by beth at 4:50 AM on March 5, 2007


Oh cruel irony... this has nothing to do with the question except that I still haven't fixed the problem, months later. I'm trying to watch more DVDs and this AskMe was the 2nd result when I googled for help.
posted by MadamM at 8:59 PM on July 31, 2007


Holy crap... I figured it out! If anyone else comes across this, it was the sound settings... changed it to stereo and it worked beautifully. Still dunno why they won't even *play* in windows media player... Oh well. At least I got to watch my move :).
posted by MadamM at 11:45 PM on July 31, 2007


« Older Teach me how to transition to ...   |  When I run, my mind gets left ... Newer »
This thread is closed to new comments.