Skip

How to share files between two computers connected by a router?
January 17, 2007 4:07 PM   Subscribe

Two computers, one router, no file transfers

I want to transfer some 20 gigs between two computers.
They're in the same room, connected via a router.
Both of them are running Win XP.

I have a ISP Branded D-Link router - DSL-604+. I connected both computers to the router, gave them the same workgroup name, but they do not show up on the other computer's workgroup network places view.

I tried running the FileZilla FTP server, and connect to FTP with IP - no such luck. I could not find proper FileZilla FTP Server documentation anyway, so it was a shot in the dark.

The Microsoft help files and internet guides about settings workgroups are no help at all.

I am getting packets when I ping the other computer - it's the MS Network interface which is problematic.

I really want to do this without spending money and without transferring hard discs. Please help me find a (somewhat) elegant solution.
posted by ye#ara to Computers & Internet (11 answers total)
 
Type \\ip.of.other.computer into the address bar of an explorer window?
posted by wierdo at 4:09 PM on January 17, 2007


Hopefully, at least one of them is running XP Pro.
If so, remote desktop connection may be the way to go.
posted by seanyboy at 4:23 PM on January 17, 2007 [1 favorite]


You got an over-zealous firewall running on one of those?

Alternatively, if you've got a DVD writer it might actually be faster to burn those files across four discs and Sneakernet it over.
posted by chrismear at 4:23 PM on January 17, 2007


Are you sure that remote filesharing is enabled on both XP boxes? As I recall, the out of the box configuration is for it to be disabled. The network setup wizzard in the control panels folder will walk you through the steps (including opening up the windows firewall)
posted by Good Brain at 4:25 PM on January 17, 2007


For quick FTP transfer, you probably can't do better than SlimFTPd. But it's difficult to answer your question without have a look at your router settings (much easier if you just had a dumb switch).

Can you disable Windows Firewall on both PCs?
Do both PCs have Windows File and Pring Sharing turned on?
Can you disable any firewall on the router? If you log into the router, does it show both PCs as being connected to it? What are their IPs?
What error did you get when you tried connecting with FTP?
On the computer running the server, did it log any attempt to log in, and give a reason for denial, or did the connection attempt not even get to the server?
Have you followed wierdo's suggestion? Did you get an error? Trying to connect to the IP address directly in Windows Explorer is a pretty fail-safe way of working out if there's some kind of network connectivity problem / firewall.
posted by Jimbob at 4:29 PM on January 17, 2007


Do both machines have a network share set up? I recently found that this was an easy fix for a networking problem I was having -- one of my XP pro machines couldn't see the workgroup until I did this (probably just forces some filesharing setting I had overlooked to ON, but hey, it worked!)
posted by misterbrandt at 4:37 PM on January 17, 2007


I had the same situation and i've been using hamachi
and i've been successful in transfering the files I need....though I want to take the seanyboy's reccomendation , since I wouldn't want to depend on a freeware 3rd party app to never lat me down.
posted by stavx at 4:59 PM on January 17, 2007


If one or both are running XP Home you may have problems - some of the network issues were "simplified" in Home.

You can try the following:
  1. Check file sharing. Is it enabled on both? If you have no sharing enabled, they may not show up on the network.
  2. Check to see if you are currently sharing any folders. If you have no active shares, again the computer may not show up on the network. Share a subfolder, not the entire drive. I like to make a "C:\Share" folder or create a "C:\temp" folder and share that, rather than sharing directories that have actual important things in them.
  3. Check to see if doing Start --> Run --> "\\NameOfComputerToConnectTo" or "\\IP.Of.Computer.###" will find it. If you can ping it, you ought to be able to find it this way.
  4. Check user accounts. Running as standard user or admin? Password protected? Same account name/password on each, or different? If different you'll need to enter credentials (as NameOfComputerToConnectTo\UserNameOnThatComputer) when prompted.
  5. Check to see if "simple file sharing" is enabled. I personally hate this and turn it off, but then again I know how to set the more advanced settings for user or group-level sharing and security. Simple sharing basically means the folder is either open to all or not open period.
  6. Check the router. Is it configured to allow file sharing or does it have some sort of firewall set up that blocks this locally?
  7. Check the software firewalls on both computers. Are you using the built-in Windows firewall, some third party firewall, or both? Running more than one firewall will screw things up. Pick the one you like best and disable or uninstall the others. Make sure both computers are using the same firewall. Check the firewall settings to be sure that file sharing is enabled.
If none of the above help, well, I've seen computers that were for all intents and purposes identical, with the same configuration, on the same local subnet, in the same room, that never successfully "talked" to each other. Windows networking is not especially solid and can quite often be a complete mystery.
posted by caution live frogs at 10:04 PM on January 17, 2007


i use foldershare. its a service by microsoft which automatically syncs two computers. you can create/choose a folder on both computers and sync them.
posted by NAPO at 10:54 PM on January 17, 2007


Thank you all for the suggestions.

I've finally managed to copy those files. Apparently, both computers had their firewalls on.
Once I turned them off I could see the other computers on the workgroup but file sharing was turned off automatically. Then I played around with the user accounts on my computer without much success - I have yet to figure out how to configure my computer to allow users to log into the shared directories [simple sharing is on].
Finally, I did it backwards - wrote the files to the shared folder on the other computer. Networking with windows is such a pain.
posted by ye#ara at 12:37 AM on January 18, 2007


The easiest way through the Windows authentication maze is for both computers to be using the same username and the same password, and for that password not to be blank.
posted by flabdablet at 3:52 AM on January 18, 2007


« Older Is this identity theft, or som...   |  Hello there Bay Area worker be... Newer »
This thread is closed to new comments.


Post