Join 3,494 readers in helping fund MetaFilter (Hide)


Why is my video/image quality grainy?
December 9, 2006 10:55 PM   Subscribe

20" LCD Monitor + GeForce Video Card = Grainy Images/Video.

I just built my first computer. My video card is a PNY Verto GeForce 7600 GS and my new LCD monitor is the 20.1" LCM-20v5 from Westinghouse. Both of them have pretty good ratings from what I can tell.

I installed all the drivers that came with the video card, and have tried both a VGA cable, with and without the DVI adapter, and just a straight DVI cable but my monitor quality is still giving me two major problems:

1) The max resolution is 1400x1050, which is the only one I can use, otherwise all text looks blurry and blocky, like there's no anti-aliasing.

2) All images and video, regardless of format or codec, look grainy. It's like I can see the tiny dots making up the picture, or see the different layers of shading. This is especially noticeable for dark colors. I was hoping to have some good quality DVD playback, but it looks like I'm watching a good quality VHS instead. Nothing is crisp or clear.

I've played around with the advanced options that the nVidia card offered, but had no luck. I reset it to default so I'm not working against myself. I know nothing about video card stuff, so I'm hoping I'm just making some newbie mistake. Am I?
posted by jimdanger to Computers & Internet (9 answers total) 1 user marked this as a favorite
 
1) Yes, that's right, you have to run it at the "native" resolution or it looks crap. That's normal.

2) Sounds like the monitor is so good you're seeing how bad normal video is. Even a DVD is only 720x480 (for NTSC) or 720x576 (for PAL/SECAM), so your new monitor is probably showing movies at nearly double the resolution they've been distributed in -- making them blocky even before you factor in the compression. Dvix/Xvid compression will be even more obvious unless professionally done.

Try a High Definition Divx from one of Divx's vlogs and report back on that.
posted by krisjohn at 11:13 PM on December 9, 2006


You'll want to download the latest drivers from Nvidia's website; the drivers on the cd are probably several months old by now, video card drivers get updated fairly regularly.
posted by bizwank at 11:15 PM on December 9, 2006


Have you loaded the correct colour profile for the monitor? It will be on the cd that came with it.
posted by kenchie at 11:32 PM on December 9, 2006


You could trouble shoot this in a few minutes if you had an extra monitor and video card. Have you tried connecting the monitor to another computer?

My feeling is that it's a video card / driver problem - possibly something related to the color profile kenchie mentioned. Uninstall and reinstall new drivers?
posted by wfrgms at 12:51 AM on December 10, 2006


I suspect krisjohn is right, you've probably never watched a DVD up close on a sharp high res display before..? I'm guessing you've also mostly used CRT monitors in the past, and so the sharpness is particularly jarring.
posted by malevolent at 1:24 AM on December 10, 2006


Sounds like you are running 8 or 16 bit color, which probably means you don't have the drivers installed and are using the generic Windows driver.

Install the drivers and it should set the resolution and color depth, provided you are using the DVI cable (which you should!)
posted by mphuie at 1:44 AM on December 10, 2006


and turn on clear type. it's designed for LCDs
posted by jaded at 4:19 AM on December 10, 2006


Running with 8 bit color would certainly do it, but I have a feeling jimdanger is smarter than that. Everything would look like absolute crap in 256 color mode, and he did say that he installed the drivers. And whatever came with the card will be perfectly fine for 2D use and watching movies. The updates they make to drivers are almost always related to supporting new games and improving 3D performance. (If you don't believe me, just read the PDF that is released with every Forceware version, it tells you exactly what has changed between every version.)

My guess is that your overlay gamma is set way out of wack. Most video playback uses the overlay mixer, which has its own gamma and brightness settings from the regular desktop gamma and brightness settings. Make sure you run the "display setup wizard" in the Forceware options, which will guide you through setting the correct gamma for the desktop. Then on the settings page switch to the settings for the overlay and make sure it's not something totally out there. Use the "Reset to default" if you need to. And also realize that often these drivers have the overlay settings set to have the color contrast and gamma set a little higher on the overlay, I guess because some marketing wizard thought it would make video playback "pop" more, but I can't stand that effect so I always reset the overlay settings to 100% and 1.0 gamma, and then tweak to taste from there. You can try setting the overlay gamma to the exact same value/curve as you have the desktop setting from the wizard, for example.
posted by Rhomboid at 10:13 AM on December 10, 2006


(And just to clarify, I totally support the notion that you should use the current latest non-beta, WHQL-approved version of every driver, so he should certainly install the latest forceware. But I certainly expect that what came on the driver CD of a new card will be good enough for standard 2D and non-gaming use, and I seriously doubt it would be at fault for whatever he's experiencing.)
posted by Rhomboid at 10:15 AM on December 10, 2006


« Older My boyfriend's 5-year-old son ...   |  What's a small, free program t... Newer »
This thread is closed to new comments.