Join 3,512 readers in helping fund MetaFilter (Hide)


Attn: Networking Gurus - Help me not break my internet connection!
November 12, 2006 5:35 PM   Subscribe

How can I make my computer trust it's wireless connection to get to the internet? I have a Windows XP professional system with a wired connection through a local router to a softmodded Xbox and a wireless connection (USB adapter) that connects to a router in another room and out to the internet. Every time I enable the wired connection, I lose the ability to connect to websites. (Extended details inside)

As far as networking stuff goes, I know just enough to get myself lost. It seems like this is a DNS issue of some sort, because connecting via ip address seems to work on both connections with both enabled (I.E. I can get to my xbox on the wired connection and my Tivo on my wireless at the same time, both set to static IP addresses.) Websites just time out.

My wired side uses IP static IP addresses in the 192.168.2.x range. My wireless side uses addresses set by DHCP in the 192.168.0.x range, except for the Tivo, which is static at .200.

My understanding of the whole routing thing was that routers were supposed to build a list of what is where. This doesn't seem to happen, or at least I don't have it set up right. Shouldn't the two routers involved see that there's a clear deliniation with the two different subnets?

Can anyone provide a layman's explanation of how to fix this? Or perhaps a pointer to a for dummies style site for making two networking connections in one box work correctly?

The eventual goal of this project is to be able to stream TV from my computer to the Xbox without killing my internet connection (there's no other TV source on this end of the house; currently I have to enable the connection long enough to upload video to the Xbox HD, then disable again to use the internet).

Thanks in advance, all.
posted by neolith22 to Computers & Internet (7 answers total)
 
Go into your Network Control Panel. Right-click on the Connection for your wired network card and select Properties. Double-click on "Internet Protocol (TCP/IP)". Delete the IP address in the "Default gateway" box.
posted by krisjohn at 5:53 PM on November 12, 2006


Actually, you just need to set up Windows XP Internet Connection Sharing on your wireless connection. That effectively turns on routing on your Windows XP box, making it able to route packets between the two networks it is part of, and directing it to use the wireless network as the gateway for the Internet. You could just connect your Xbox locally on a wired switch with your XP machine, as there is no need for a second router. Turn on your XP firewall for the wireless connection only, as your wired connection should be trusted machines only.

There is one built-in limit in Windows XP in doing this, however, which is that Windows XP will automatically make its own wired connection 192.168.1.1 and turn on it's DHCP server on the wired port. So, you're going to need to make your Tivo on the wired link pickup its address from the Windows XP DHCP server, or give it a static address of 192.168.1.200 and a gateway of 192.168.1.1, and appropriate DNS entries, too, if Tivo needs them. The other downside is, that since your Windows XP box is routing, it has to be on for your Tivo to see the Internet.

In theory, you could bridge the wireless and wired connections with your XP machine, but I don't recommend it for what you are trying to do. Few XP applications will expect to operate in a bridging environment, and it makes firewalling difficult and not very reliable.
posted by paulsc at 6:51 PM on November 12, 2006


Whelp, it's working now. Slowly.

Krisjohn - removing the gateway has me up and running, but webpages are taking about 4x longer to load - seems like it's looking on the wired network first, then moving on to the wireless after a short timeout, as images and page elements are the part that's slower. Actual transfer speed seems to be about right. This is livable, but if it suggests a further problem you might have a solution for, I'm all ears.

Paulsc - the wizard bombed out on me - just got to the end of the questions and gave a screen indicating that an error occured.... with no detail about what that error was. There was an "Internet gateway" that showed up, disabled, in my network connections, for about 30 seconds. I could connect to both networks while it was there, but after windows finished it's cleanup and removed the gateway I was back to broken. I'm guessing that means that you were right about this being a solution for most people in my situation, but the wizard doesn't like this particular setup for some reason.

Thanks to you both for your help!
posted by neolith22 at 11:26 PM on November 12, 2006


If you post the results from typing "route PRINT" into a command prompt, I can probably speed up your connection.
posted by krisjohn at 12:20 AM on November 13, 2006


Gladly!

===========================================================================
Interface List
0x1 ........................... MS TCP Loopback interface
0x10004 ...00 0d 87 bb 53 e7 ...... VIA PCI 10/100Mb Fast Ethernet Adapter - Packet Scheduler Miniport
0x20003 ...00 0f b5 d9 74 d4 ...... NETGEAR WG111v2 54Mbps Wireless USB 2.0 Adapter - Packet Scheduler Miniport
===========================================================================
===========================================================================
Active Routes:
Network Destination Netmask Gateway Interface Metric
0.0.0.0 0.0.0.0 192.168.0.1 192.168.0.102 25
127.0.0.0 255.0.0.0 127.0.0.1 127.0.0.1 1
192.168.0.0 255.255.255.0 192.168.0.102 192.168.0.102 25
192.168.0.102 255.255.255.255 127.0.0.1 127.0.0.1 25
192.168.0.255 255.255.255.255 192.168.0.102 192.168.0.102 25
192.168.2.0 255.255.255.0 192.168.2.200 192.168.2.200 20
192.168.2.200 255.255.255.255 127.0.0.1 127.0.0.1 20
192.168.2.255 255.255.255.255 192.168.2.200 192.168.2.200 20
216.221.57.32 255.255.255.255 192.168.0.1 192.168.0.102 25
224.0.0.0 240.0.0.0 192.168.0.102 192.168.0.102 25
224.0.0.0 240.0.0.0 192.168.2.200 192.168.2.200 20
255.255.255.255 255.255.255.255 192.168.0.102 192.168.0.102 1
255.255.255.255 255.255.255.255 192.168.2.200 192.168.2.200 1
Default Gateway: 192.168.0.1
===========================================================================
Persistent Routes:
None

See anything blatantly wrong? Thanks again!
posted by neolith22 at 8:10 AM on November 13, 2006


Looks ok.

On that page where you deleted the gateway, you could also try removing any DNS entries (though save them incase you need to add them back, I'm not sure if DNS settings are shared across interfaces).
posted by krisjohn at 3:52 PM on November 13, 2006


Looks like the router started figuring out where things were after all, once the spare gateway was removed. Speed of DNS lookups returned to normalish over the next 24 hours.

Thanks again for your help!
posted by neolith22 at 9:32 AM on November 15, 2006


« Older "Amazing Dryer Balls"...   |  Do research scientists have so... Newer »
This thread is closed to new comments.