Thunderbrd and inline images
October 14, 2006 7:08 PM   Subscribe

How can I stop thunderbird from automatically rendering inline (attached) images?

So Thunderbird is already blocking remote images, but what I want it do is also block images which are included as attachments to the message and displayed inline via HTML (mostly because most of the spam that gets through my filters consists of a big annoying image). I'm sure there's a way I can do this by messing around in the user CSS or XUL files, can anyone help with this, or at least point me in the right direction?

My ideal solution would replace the image with some sort of DHTML widget that I could click on to display the image (similar to how the FlashBlock Firefox extension used to work). Every now and then a friend sends me an actual photo or something that I'd like to look at, and it would be nice to do so within thunderbird instead of looking for the attached image and opening it seperately.
posted by whir to Computers & Internet (5 answers total)
 
Have you unchecked 'View>Display Attachments Inline'?

I think that's what you're looking for.
posted by chrisamiller at 8:35 PM on October 14, 2006


*smacks head*

Thanks, that was easy.
posted by whir at 8:57 PM on October 14, 2006


You can also put a button on the toolbar to toggle image loading, and a button to toggle HTML viewing. I have mine set to display the plain text content (HTML off) and if the HTML is turned on then it still has the images defaulting to off.

Some of these capabilities might be part of the "Buttons!" extension.
posted by intermod at 11:19 PM on October 14, 2006


Ok, I thought this was too easy. As it turns out, I still have a problem with some spam messages displaying inline images even when I have the "display messages inline" option turned off. Looking at the source, these images appear as

<img src="cid:000b01c6f2cd$4bdf7130$9a936dd9@FREDERIQUE" ...>

Can anyone shed some light on this? That isn't an encoded IP which causes TB to fetch the image from a remote host, is it? I've never encountered the cid: protocol before.
posted by whir at 11:01 AM on October 18, 2006


Examining the email a little more closely, the cid: identifier is then included in a Content-ID: header farther down in the email, followed by a base64-encoded dealie which is presumably the image in question. I suspect there is some kind of Thunderbird bug which makes it ignore the "display inline attachments" option in some cases, and my particular spammers have figured out how to trigger it. I'll try grabbing that Buttons extension and playing around with it, though, maybe it sets something deeper in the prefs.
posted by whir at 5:51 PM on October 18, 2006


« Older Where do these images of a 195...   |  London, Paris or elsewhere for... Newer »
This thread is closed to new comments.