Skip

Assigning Drive Letters
August 11, 2006 10:05 AM   Subscribe

Is there a way to get Windows XP to always assign the same drive letter to a particular removable device?

Specifically, I have a thumb drive, and an MP3 player that's also a drive. I would like each of these devices to always get assigned the same drive letter, for example D: for the MP3 player and E: for the thumb drive.

If I plug in the thumb drive by itself I don't want it to be D, I want it to be E. Is there any way to do this?
posted by king walnut to Computers & Internet (4 answers total) 2 users marked this as a favorite
 
Adminstrative Tools -> Computer Management -> Drive Managent -> Right Click, Change Drive Letter. Whatever letter you pick should remain the same everytime you plug the device in. YMMV
posted by blue_beetle at 10:23 AM on August 11, 2006


What blue_beetle said, except I think it's "Disk" management. At least on my computer.
posted by yeti at 10:55 AM on August 11, 2006


Also be aware that these settings only apply to the computer you make them on. As far as I know, there's no way to make a particular thumb drive consistently assign itself the same drive letter regardless of which computer it's plugged into. See this previous question for more.
posted by flabdablet at 7:25 PM on August 11, 2006


Thanks blue_beetle. Searched google everywhere to find a solution to my (similar) problem. Bought a 400gb SATA internal harddrive and a SATA-to-USB external enclosure. My computer with XP would recognize that a USB mass-storage device was connected but the drive wouldn't show up in My Computer. The computer wouldn't assign a drive letter. Google gave me lots of incorrect answers, from registry editing, to disabling a bunch of different services in safe mode, to sending the drive back because it doesn't work. Your solution worked and let me initialize the drive and format it.
posted by msbrauer at 10:42 AM on May 21, 2007


« Older What songs/artists are out the...   |  I want something that has a fe... Newer »
This thread is closed to new comments.


Post