Join 3,439 readers in helping fund MetaFilter (Hide)


External drives recognized, but not mounting
July 14, 2006 7:54 AM   Subscribe

My 2 external hard drives (that I use with my Powerbook G4), which worked fine last week, are recognized, and Disk Utility *says* they're mounting, but they do not appear on my desktop. I cannot access the files or copy new items.

I have 3 external hard drives--1 using Firewire (Maxtor Onetouch II) and 2 (both Western Digital) using USB 2.0. I have a PowerBook G4 and Run OSX v10.4.6

I recently moved and the 2 USB drives, which used to work fine, now will not mount. When I connect them to the machine, they don't pop up. When I unplug them, it gives me the shpiel about having just unplugged a device without unmounting...?

I went into Disk Utility and both appear as being recognized (the drive itself appears as the orange square with a squiggle), but the volume directory WITHIN the drives don't appear as the orange thing; they appear as white squares. I tried verifying both the the drives themselves and the volume directories within each; they verify fine. When I hit "Repair Disk" it tells me that they don't require repairing.

I have tried other USB devices into the ports on my machine and they work fine. And my Firewire Maxtor external drive works fine.

I can't get to my files and I'm totally baffled. Any help would be *greatly* appreciated.
posted by cg1 to Computers & Internet (8 answers total)
 
I run into similar problems with alarming frequency. You may be able to get to the files via the terminal. When the hard drives are plugged in, open up the Terminal and type

cd /Volumes
ls

My hunch is that the drives will appear there, even if they do not appear in the finder.

I use the usb drive that won't mount just to shuttle files, so I am happy to cp the files around and then

sudo umount /Volumes/drive_name

when I am done.

I suspect there is some corrupted pList that can fix the problem, though. If you need to work on the file you also should be able to run

open /Volumes/the_drive/the_file

and if it is clearly a word or excel or whatever doc, it should open the right program.
posted by mzurer at 8:08 AM on July 14, 2006


Maybe you just have that preference turned off in the Finder? If you go into the Finder preferences and choose the 'General' tab you'll see a bunch of checkboxes under the heading 'Show these items on the desktop'. Rather confusingly, the checkbox labelled 'CDs, DVDs and iPods' also controls whether external Firewire and USB drives appear on the desktop.
posted by boaz at 8:42 AM on July 14, 2006


Oh, I just saw that some work, while this would disable them all. Never mind.
posted by boaz at 8:46 AM on July 14, 2006


Select the drive in disk utility and in the info at the bottom, click the blue link to the right of where it says "Mount Point". That should open the drive in the Finder.
posted by cillit bang at 8:58 AM on July 14, 2006


if you open Terminal and do 'mount', it'll tell you all the volumes that are mounted. you can also try going to Go to Folder under the Go menu in Finder and telling it to go to /Volumes - they might appear under there if they are indeed mounting correctly. (this is kinda an alternate method to mzurer's idea.) if you get to it through /Volumes in the Finder, it might figure it out and go "hey! volume! duh!". (or, it might not. Finder works kinda weirdly sometimes.)
posted by mrg at 9:34 AM on July 14, 2006


I had the same problem with a Western Digital firewire drive on my G4 desktop. I ended up having to use Norton Utilities to fix the problem; I ran disk repair and it repaired the read-write permissions. I had the same thing happen two or three times, but it hasn't happened since I moved to a new computer. I was using OS X 10.3 at the time, but otherwise sounds very similar to your problem.
posted by TedW at 10:59 AM on July 14, 2006


You might check your console logs right after you try mounting them and see if there are any suggestive errors there.
posted by advil at 11:44 AM on July 14, 2006


DiskWarrior fix everything.
posted by pmbuko at 12:09 PM on July 14, 2006


« Older Looking for a wheel kit for my...   |  I've known a great guy for abo... Newer »
This thread is closed to new comments.