Join 3,512 readers in helping fund MetaFilter (Hide)

Tags:

How to get computer to recognize USB thumb drive
June 9, 2006 7:17 AM   Subscribe

What can I do to get my computer to recognize my USB thumb drive?

It's worked previously: plug it in, the computer recognizes it's there, voila. Today, nothing. Anything I can do manually to get my computer to recognize the USB drive?

It's a Memorex travel drive and says "USB 2.0" on the bottom, if that helps.
posted by bison to Computers & Internet (7 answers total)
 
Oh, and computer is WinXp, SP2
posted by bison at 7:21 AM on June 9, 2006


try putting it in different USB ports? sometimes these devices only work in the port they were originally put in.
posted by altolinguistic at 7:34 AM on June 9, 2006


Yes, alto, I tried that. Tried every port. 2 in front, 4 in back. No luck.

The kicker is that I had a co-worker plug it in his machine, and it came right up.
posted by bison at 7:43 AM on June 9, 2006


Did you power off and power back on your machine? Did you check the USB ports with other devices to make sure the ports are working?
posted by SeizeTheDay at 7:48 AM on June 9, 2006


I had a similar problem. It is listed as drive G, but the machine is already using drive G. You need to rename the USB drive.

Control Panel: Administrative Tools: Computer Management: Disk Management: find the USB drive and rename it.
posted by Classic Diner at 8:26 AM on June 9, 2006 [1 favorite]



my problem previously also.
posted by busboy789 at 8:54 AM on June 9, 2006


Classic Diner's answer was the closest to getting it fixed.

The solution was in the Hardware > Device Manager screen, it had been disabled. Re-anabling it got it come up just fine.

It did not, though, need to be renamed.
posted by bison at 8:57 AM on June 9, 2006


« Older Hi, wondering if anyone's had ...   |  Linux to Mac SSH connection: W... Newer »
This thread is closed to new comments.