MacOSX: Pasting text when edit menu is disabled?
June 5, 2006 12:58 PM   Subscribe

Mac OS X: Is there any way to paste text when a program disables the edit menu? With Quicksilver, maybe?

I'd like to paste addresses into my label making program (Brother's P-touch Editor v.3.2), but unfortunately, it's pretty badly programmed, and disables the edit menu when I bring up the dialogue box to insert text. Is there a way to get around this. perhaps with Quicksilver?

(Note: While I'm not very experienced with QS, I tried to take some text, copy it to QS's clipboard, bring up the clipboard when the Label software's dialogue box was open, and paste it without any luck. Dragging and dropping the clipboard entry doesnt work either. Any ideas?)
posted by sdis to Computers & Internet (19 answers total) 1 user marked this as a favorite
 
Have you tried CurlyThing-V on the keyboard?
posted by unixrat at 1:13 PM on June 5, 2006


It is, by the way, technically "Swedish-Campground"-V. ;)
posted by NucleophilicAttack at 1:17 PM on June 5, 2006 [1 favorite]


It was much easier when it was "OpenApple"-V. :)
posted by unixrat at 1:18 PM on June 5, 2006


Control-clicking in the input box and selecting "paste"?
posted by blag at 1:23 PM on June 5, 2006


If it's badly (enough) programmed, then you'll need to use something that turns clipboard contents into emulated keystrokes in order to get the content into a text field. I am not aware of any such software, though.
posted by pmbuko at 1:43 PM on June 5, 2006


⌘-v ( ⌘ )
posted by voidcontext at 1:44 PM on June 5, 2006


Oops, formatting didn't make it through.
posted by voidcontext at 1:45 PM on June 5, 2006


Apple-V - tried that.
Control Click: No luck getting contextual menu
posted by sdis at 3:01 PM on June 5, 2006


pmbuko: I think it is that badly programmed. :P
posted by sdis at 3:02 PM on June 5, 2006


The QuickSilver action that you want to use when the clipboard item is selected is "Type Text". I can try to explain it in more detail later.
posted by the biscuit man at 4:42 PM on June 5, 2006


biscuit: Didn't know there was such an action.

Surprisingly, it didn't work in this program.

I copied some text to the clipboard, hit "Type clipboard" in QS, and it beeped a few times. Nothing was pasted. I tried this in Textedit and it worked just fine.
posted by anonymoose at 5:33 PM on June 5, 2006


Well this is weird:

The program doesn't in fact disable copying and pasting. I can cut, copy, and paste text that I type inside the text field of the program. But if I try and bring in clipboard stuff from outside of the program, no luck.

Ideas?
posted by sdis at 5:38 PM on June 5, 2006


This page about the utilities pbpaste and pbcopy (second item down) seems to suggest that there's more than one clipboard on OSX. Maybe that explains it?
posted by AmbroseChapel at 6:04 PM on June 5, 2006


There's only one clipboard, but it can contain multiple versions of the same thing in different formats. It might be that the Brother thing is expecting a format that the program you're copying from doesn't supply.

So try experimenting with using different programs as the source of the text you want to paste.
posted by cillit bang at 6:42 PM on June 5, 2006


Sometimes you can select text, then drag it into a field in another application.
posted by clango at 9:13 PM on June 5, 2006


For the Quicksilver type text thang, you probably need to enable access for assistive devices. Do the following:

- Launch System Preferences from your Dock or your Apple menu.
- Choose the Universal Access preference pane
- Check the box marked "Enable access for assistive devices".
- Relaunch your application of evil.

What enabling this checkbox does is enable your UI to be controlled via Apple Events, which is how the Quicksilver command is doing its mojo. It's disabled by default because it's conceivable that someone somewhere could write a bit of malware that would type out "I love Santorum!" into your docs at random.
posted by smeger at 2:11 AM on June 6, 2006


Once you've done this, you'd use the Quicksilver command as follows:

- Bring QS frontmost by invoking it using control-space or whatever key combo you've set.
- Hit the period key on your keyboard to switch to text entry mode.
- Paste text by typing cmd-v on your keyboard.
- Hit tab to move to the next field in Quicksilver
- Type or select "Type Text" until that's the selected command.
- Hit "return" on your keyboard to execute that command.

Good luck!
posted by smeger at 2:14 AM on June 6, 2006


It looks like smeger explained it fully. Once you follow his directions you should be set.

If you have any interest in AppleScript, you could also set up a script that would parse the entire address from the clipboard and automatically enter it into the application using GUI scripting. I've done something very similar using SwordfishExpress.

If you would like some help, contact me through the email in my profile.
posted by the biscuit man at 7:03 AM on June 6, 2006


Works like a charm. Thanks
posted by sdis at 3:08 PM on June 8, 2006


« Older I have an itch....   |  I have here in front of me a c... Newer »
This thread is closed to new comments.