Join 3,556 readers in helping fund MetaFilter (Hide)


squeezing audio from a video podcast
April 28, 2006 11:23 AM   Subscribe

Is there a way to play the audio from video podcasts on my iPod?

I have several .m4v and .mp4 files and when I drag them to my iPod nothing happens. Normal podcast files transfer fine of course.

I have tried the "Convert Selection for IPod" in iTunes and it says that the files already are in the correct format.

I have found a million hacks to actually play the videos on my Nano but I really do not care about that - all that I really want to be able to do is to listen to the podcasts while driving to work. I can always watch the video when I actually am at my computer.

I am on a PC, using ITunes 6.0.4.2 with iPod software version 1.1.1.
posted by GrumpyMonkey to Technology (6 answers total)
 
If you can get the videos to play on your iPod, why not just play the videos and don't look at the screen?

Otherwise, you're in for a slow and painful process for each file you want to listen to -- you'll have to use video editing software to dump the audio track of the video to a file, then possibly convert that file to MP3 or AAC. Alternately, you could play the video and use audio capture software to grab the audio.
posted by jjg at 11:33 AM on April 28, 2006


I put a movie into a music playlist and it just played the audio with no video on my ipod. Try it, I bet it works.
posted by mathowie at 11:54 AM on April 28, 2006


I would imagine since it's a Nano that the ability to decode the audio stream of a video file isn't in the firmware, although I'm not sure. Your best bet would be to use QuickTime Pro (or another video processing tool) to create a separate audio track with no video content.
posted by mikeh at 11:56 AM on April 28, 2006


jjg - the problem is that i do not want to have to hack my ipod to get the videos to work, there seems to be a lot of potential for frying it.

mathowie - sadly, that does not seem to work for me.

Thanks for the suggestions, I will try to extract the audio I guess like.
posted by GrumpyMonkey at 12:49 PM on April 28, 2006


Try adding 'Podcasts' to the main menu, and selecting the video postcast from there. When i do that on my Video iPod, i get just the audio. To play the video i have to select Videos->Video Podcasts.
posted by Davidicus at 3:56 PM on April 28, 2006


Davidicus: "Try adding 'Podcasts' to the main menu, and selecting the video postcast from there. When i do that on my Video iPod, i get just the audio. To play the video i have to select Videos->Video Podcasts."
Uh, assuming that you can get the videos on there in the first place, i must have missed the Nano part on my first readthrough.
posted by Davidicus at 3:57 PM on April 28, 2006


« Older please help me help my girlfri...   |  I'm trying to find studies or ... Newer »
This thread is closed to new comments.