Skip

Why can't I open pdf's in Firefox?
April 19, 2006 10:45 PM   Subscribe

Recently, Acrobat has stopped opening pdf's in my firefox browser. It works fine in internet explorer, but I'd rather stay away from that particular program. I've tried reinstalling, updating, changing preferences and more. Anybody else experiencing this?

When I click on a pdf link in my firefox browser, i get the error message "cannot use Adobe Reader to view pdf in your web browser. Reader will now exit. Please try again." Needless to say, retrying doesn't work.

I have uninstalled version 7.0, then reinstalled. I also made sure all older copies are removed completely. I set the prefrences on Acrobat so it wouldnt try to open files in the browser, but open seperately, but that had no effect either.

I use Norton Antivirus, and Zone Alarm, but I didnt see any place for program permissions on Norton, and Zone Alarm has Adobe set as having full permission.

I've tried googling my problem, but even that has failed me. Please help! I'm working on my thesis, and things would work a lot more smoothly if I didnt have to switch to IE just to read articles.
posted by gilsonal to Computers & Internet (12 answers total)
 
Since Firefox has automatically downloaded updates to my browser I have noticed a few bugs. I don't know if this is related. Try system restore back a month, and see if Acrobat works. You can always undo the restore.
posted by weapons-grade pandemonium at 10:59 PM on April 19, 2006


I recommend Foxit.
posted by Manjusri at 11:58 PM on April 19, 2006


Have you also reinstalled Firefox followed by reinstalling Reader?
posted by junesix at 12:03 AM on April 20, 2006


Have you disabled any of Reader's plugins (normally done as a speed tweak). Other things to check would be about:plugins, and to check Tools>Options>Downloads>View & Edit Actions.
posted by unmake at 12:34 AM on April 20, 2006


Did you recently upgrade to Acrobat 7? I had the same problem, and I was finally able to solve it this way (this assumes you are running Windows):

Go to c:\Program Files\Adobe\Acrobat 7.0\Reader\Browser (or whatever the corresponding path is on your computer)

Find nppdf32.dll.

Copy it into your Firefox plugins folder, which is probably at c:\Program Files\Mozilla Firefox\plugins. (There might already be a copy there; if so, this is the old version, so go ahead and overwrite it with the version you copied from the Acrobat 7 folder.)

This fixed the problem for me, and hopefully it will for you too.
posted by Aster at 1:05 AM on April 20, 2006


Aster's fix looks right to me, assuming you actually want to stick with Acrobat. Me, I haven't used anything but Foxit Reader since first trying it. Firefox treats it as a helper application rather than a plugin, but for me the slight inconvenience of having to close a blank tab for each PDF is more than made up for by Foxit's sheer unbloated speed. It's a beauty.
posted by flabdablet at 2:42 AM on April 20, 2006


I second the FoxIt reader suggestion.
posted by purephase at 5:11 AM on April 20, 2006


Aster, I tried looking in the browser folder, but it was totally empty. Maybe thats the reason I'm having a problem. Odd, because the install said it worked fine.

I've also tried installing foxit and setting it as default, but Adobe keeps popping up. I'll uninstall it and see if I cant get it to work. Thanks!
posted by gilsonal at 5:54 AM on April 20, 2006


Get foxit, unless you're prohibited for whatever reason. I find it so much faster than Acrobat that it's laughable. heh.
posted by jikel_morten at 6:11 AM on April 20, 2006


Well, unfortunately, now with Foxit installed and Adobe gone, pdf's dont open at all. Any other ideas, besides a system restore?
posted by gilsonal at 6:45 AM on April 20, 2006


Ok, I think I fixed it. Even with it set to have FoxIt as my default, my Firefox still had pdf extensions set to open with Adobe. I changed that, and now everything works fine. Thanks for all the help, everybody.
posted by gilsonal at 6:56 AM on April 20, 2006


And now I have Foxit, also, and don't have to wait for all those Acrobatics to load.
Thanks, Manjusri.
posted by weapons-grade pandemonium at 8:06 AM on April 20, 2006


« Older MoneyFilter: What should I do ...   |  I need to get on the right tra... Newer »
This thread is closed to new comments.


Post