Join 3,572 readers in helping fund MetaFilter (Hide)


Why won't my web pages load on the first try?
April 11, 2006 7:31 PM   Subscribe

Why won't web pages load the first time I ask for them?

I recently got a new computer and ever since I gave my ISP the MAC address of the new computer, my internet connection has become spotty. I have bundled cable/internet/phone with Knology and a tech has come out and insured I have a good signal, so the problem seems like it is on my end. The symptoms are as follows: the browser will often give me a time-out error when loading a page (even something as reliable as Google); hitting "try again" or "refresh" will often result in the page loading instantaneously, as if it were in the browser's cache. Why didn't it just load the first time?

Technical details: Webstar cable modem (from ISP) connected via ethernet to a Netgear WGR614 wireless router (with the latest firmware); Mac G5 running OSX 10.4 and Dell Running Windows XP connecting via wifi. Using Firefox on the Dell, and Firefox and Safari on the Mac, the behavior described above happens. I have confirmed that the router is sending the correct MAC address to the ISP. What is going on?
posted by TedW to Computers & Internet (18 answers total) 1 user marked this as a favorite
 
I smell two possiblities, and both are coming from your router:

1. You're using a Bittorrent client, and leaving it running for a few days. Many routers store a cache of sites that connect to it, and Bittorrent connections will fill it up and then make your connect get wonky. To see if this is the problem, unplug your router, give it a second and then plug it back in. See if your connection works

2. The MTU size in your router is too high, and the packets are getting crunched trying to get out of your system. If it's 1500, try setting it down to 1400 and see if that helps.
posted by fcain at 7:43 PM on April 11, 2006


I'm by no means an expert at this stuff, but just from fiddling with my own internet connection, I'm confoozled: you're running this stuff through a router, why do you need to send the isp the computer's mac address? Isn't sending the router's mac address alone sufficient? My router hands out connections with dhcp, there's no need to talk to the isp every time I have a host with a new mac address.
posted by juv3nal at 7:49 PM on April 11, 2006


I had these symptoms when I switched to a new high-speed provider. They were solved by switching the default dns server to something other than the isp's default.
This remedy was suggested to me by a friend who happened to run a dns server.
posted by Zetetics at 7:51 PM on April 11, 2006


Sounds probably like a DNS issue. Try hooking a PC up straight to the cable modem (if possible), to rule out the router.
posted by cellphone at 7:58 PM on April 11, 2006


fcain: good ideas; I am not running any bittorrent clients or anything other p2p apps that hog bandwidth, so that is not the answer. The router is set up via my broswer, and I went in and changed the MTU. I then got a time out message as before, but when I reloaded the browser setup page, the settings had been changed.

juv3nal: Nice suggestions as well, but my ISP does not support any kind of home network and so they want one computer's MAC address when you get online. I have set the router to broadcast the MAC address of this particular computer (or at least one of the three MAC addresses it has with one WiFi and 2 Ethernet ports). Whenever I call the ISP for tech support, the first thing they ask me to do is bypass the router and plug in directly from the ethernet port on my computer to the ethernet port on the modem. As an example of the quality of tech supporth there, I asked if I could use a crossover ethernet cable to connect to the modem. The first level of support had no idea what I was talking about and kicked me up to the next level. The next level then ran a speed test and told me I had a good connection before telling me that crossover cables would not work; I was using a crossover the whole time, as that was the first one I found in my extra cable bin.

Anyway, the fact that I see the same behaviour when logging into my router pretty much proves that the problem is local; I will see if the MTU change helps. Thanks again for all the suggestions.
posted by TedW at 8:05 PM on April 11, 2006


Cellphone: I am getting ready to call it a day, but will try bypassing the router at some point. The router has worked well for at least a couple of years now; why would it suddenly act up? Of course I know that these things happen. I have no problem buying a new router if need be.
posted by TedW at 8:08 PM on April 11, 2006


And just to show you how bizarre this is, Mefi is currently loading fine, but Google and Salon.com (my usually reliable test sites) are slow/not loading.
posted by TedW at 8:12 PM on April 11, 2006


Have you "powercycled" the router? Unplugged its power and then plugged it back in again?

Do take a second and plug one of your computers directly to the cable modem. I'll bet your connection will work fine.
posted by fcain at 8:43 PM on April 11, 2006


If I may hijack your question...

Anyone know why sometimes I cannot access a URL if I type it into my address bar (it times out), but if I Google for that URL, and click on it from the Google search results page, it loads fine?
posted by Brian James at 8:53 PM on April 11, 2006


As someone said above, it's most likely a DNS issue, since it's happening on both the Dell and your Mac it's probably easiest to hard code it into the router. with the 614, log in to the router, click on the option on the left that says "basic settings", in the center pane, scroll down a bit and where it says Domain Name Server (DNS) Address, select "Use These DNS Servers"

For primary use 4.2.2.2 and secondary use 4.2.2.3 or if you prefer use any others that you know will work.

Next, on the left, select Dynamic DNS. Make sure this is turned off.

A couple of other points. Webstars tend to be crap. (We have had tons of problems with them where i work.) Check and see if your ISP offers any other kinds of modem. Motorola, Teyron, Linksys, and Ambit are all pretty common and probably better than Webstar.

Next, the reason they want you to bypass the router is that by default, most routers have ping disabled. It's very difficult for someone to troubleshoot a problem like this when they can't see if you connection past the modem (be it PC or router) is losing packets. Best thing to do is just suck it up and bypass, it's helps the tech who is honestly trying to help you. Though not knowing what a crossover cable is depresses me for some reason.

There is no reason you should need to set the router to broadcast a PC MAC address. The DOCSIS standard (what your cable modem uses) doesn't care if it's a router or a PC. Your ISP is just being difficult in this regard. Turn it off if you like, it shouldn't affect anything.

Bypassing the router is always a good troubleshooting step. If you are still having problems, you can put the DNS IPs on the machines themselves (let me know if you need help doing this, but it's pretty straight forward). Unlike the Webstar, the 614 is a pretty solid router. i'm guessing that it isn't the cause of your problem. But the best trick i can show you is this: if you ever have problems. Unplug the modem and router. Plug the modem back in first and wait for it to completely sync. (with a Webstar, wait about 30 seconds to a minute). Plug the router in next. Give it about 10 seconds, then if necessary, renew the DHCP on your machine.

Honestly, this fixes 99 percent of cable modem issues.

[sorry about the length.]
posted by quin at 9:35 PM on April 11, 2006


And Brian James, the trouble you are having is probably nothing more than a DNS issue as well. Try a different DNS server (the ones i listed above will probably work) If not, it could be a routing issue. Some ISPs (particularly when dealing with dial up) also use caching proxy servers which may be causing the issue. If all else fails try tracerouting to the site that you are having problems accessing. See if it times out anywhere along the way. Let your ISP know that this route isn't working.

Also, try a different web browser and make sure it isn't something silly like IE being goofy.

[goofy being a highly technical term.]
posted by quin at 9:41 PM on April 11, 2006


TedW, sorry if this is long and a bit of hijack but what you've just described sounds eerily like problems I have connecting wirelessly at my fave coffeehouse... likely to become my x fave due to the fact that I cannot beg, borrow, buy nor steal a wifi connexion there.

I have a new MacBook Pro. so far my first week with it has been amazing. this thing just works, it's fast and problem free, unlike my late, great windows crapboxes. The network connexions work seamlessly, either physically hooked up in my house (cable modem) or on wifi hotspots around town... all except for the one. And I thought about the bandwidth deal but it bears no relation to how many people are on the wifi link cos I've been the only one there and it still wouldn't work.

I love my new MacBook and the dual OS deal is tits for someone like me who has Windows separation anxiety. *however*... the wifi does sometimes act a little flakey on this thing. when on public wifi (this is a college town) I suspect its usually bandwidth issues. and because it's a mac and I'm a lifetime PC user, I'm not well equipped to ask it why it's gone all snarky with me. current solution is to just go hit another wifi spot til I find one that works; god only knows there are enough here. The one cafe I really dig, unfortunately uses a key-encrypted login, courtesy of Qwest (who suck hard, IMO) and my Mac doesn't play well with it. I have NO trouble obtaining a connexion, but it just keeps booting me back to the login/password screen and I can't get past that regardless of browser or how many times I login.

so I dunno if this is helpful but if plugging straight into your cable modem isn't a happy solution (and I can see why it wouldnt be) maybe go hit some wifi hotspots around town and I'll bet you a chai tea latte it'll work well at most of them. this might also help you establish that it's something going on with your provider. if that's the case then it's not your mac, so call your ISP and bug them until they help you solve it.

sorry this isn't more helpful, just letting you know you're not alone.
posted by lonefrontranger at 9:46 PM on April 11, 2006


To echo juv3nal's earlier response, why not just send the router's MAC?

The techs telling you they want "one computer's MAC" aren't necessarily expressing themselves as clearly as they might. As long as they get the MAC of the machine they're connecting to -- which machine happens to be, in this case, a router -- things should work.

Also, as a general resource tip in this area (not just to you but to side question posters), doing searches on Google, Google Groups and on dslreports.com for "isp name problemdescription" has worked well for me in the past. It is rare for me to be the only person with a particular problem.
posted by cps at 10:45 PM on April 11, 2006


I have more or less the same problem (minus the "I gave my ISP my MAC address"), but only for digg.com.

I know, I know - simple solution: don't go to digg dot com; voila - no problem!)
posted by Guy Smiley at 11:32 PM on April 11, 2006


Thanks everyone; I think I figured it out. fcain's answer made me look more closely at the router and looking back I forgot to mention the seemingly trivial point that I had upgraded my router's firmware a few days ago. Afterward I did not clear my router's configuration settings as instructed to; I wrongly assumed a simple reboot would do. After going back to netgear.com and following the instructions precisely this time, and reconfiguring the router from scratch, everything seems to be hunky-dory again.

For those of you who were wondering about the MAC address, my ISP asks you for the MAC address of your computer when you sign up, afterwards you can only connect using that MAC address. When you get a new computer it will not work until they have the new MAC. I could have given them the router's MAC address, but way back when I first got the router I configured it to spoof the computer's MAC. This works best when as mentioned above, I have to bypass the router for troubleshooting.
posted by TedW at 4:22 AM on April 12, 2006


Another thing you can do to bypass having to register all your MACs is change the MAC on the machine your having troubles with to the MAC you originally registered (don't forget to change it back after you've finished trouble shooting and have reconnected your router).
posted by Mitheral at 7:27 AM on April 12, 2006


Glad to hear your issue was solved!
posted by cellphone at 4:57 PM on April 12, 2006


Glad that I got no RTFM comments!
posted by TedW at 9:36 PM on April 12, 2006


« Older Can a Priest from a High episc...   |  Where can I find an elastic fi... Newer »
This thread is closed to new comments.