Join 3,556 readers in helping fund MetaFilter (Hide)


iTunes Laptop/Desktop Blues
April 11, 2006 2:21 PM   Subscribe

How do I get iTunes to stop reverting the music folder back to my local laptop drive every time I leave the house? How can I play music that is housed on my desktop from my laptop through my stereo receiver?!

I listen to music at home much more than at work. I have a large mp3 collection (12,000+ songs) that I keep on a desktop computer that simply acts as a server. I call it the G drive. I do all my computing on my laptop, which I bring to and from work. Its hard drive is the C drive. In iTunes, I have G:\My Documents\My Music\iTunes as my Music folder location, so that I'm not filling up my laptop hard drive with all these music files. I have both "Keep iTunes music folder organized" and "Copy files to iTunes music folder when adding to library" checked in my Advanced preferences. When I listen to music at work (which isn't that often), I'm fine with listening to CD's or my iPod. Home is where music matters.

Here's the problem: Every day I go to work and use my computer, and regardless of whether I actually use iTunes or not, I come home, and the iTunes music folder in Advanced preferences has reverted back to the iTunes folder on the C drive. Every day! It's driving me nuts, and I'm not sure why it does this.

Also, any tips on playing music at home from my laptop through my stereo? I'm pretty sure it's possible because at one time, a friend was able to get music on the desktop computer (the one that acts as a server) to play through the stereo. I just had to log on to that computer remotely and play from iTunes there. Surely, I could do that more directly.

(I do apologize if this has been asked before, but I did look for a while and came up with nothing specifically geared towards my question.)
posted by abbyladybug to Technology (13 answers total)
 
For the second part of your question, I like my Airport Express.
posted by kcm at 2:24 PM on April 11, 2006


It seems you're not the only one reporting this problem. This guy suggests replacing the ~/Music/iTunes folder with an alias to the correct location (your G drive) as a kludge. It'll spit out an error when you detach your laptop but it won't revert to the local laptop hard drive.
posted by junesix at 2:33 PM on April 11, 2006


You want to turn on "Share my music" in the iTunes preferences on your desktop, and "Look for shared music" on your laptop.

The songs & playlists on your desktop computer will show up in iTunes on your laptop computer whenever you connect to your home network. The location of your "Music" folder on the laptop will be irrelevant.
posted by designbot at 2:39 PM on April 11, 2006


(Note that iTunes will need to be running on both computers for this to work.)
posted by designbot at 2:41 PM on April 11, 2006


Airport Express is da bomb. Or whatever the young folks say these days.
posted by unSane at 2:47 PM on April 11, 2006


I'll second the Airport Express.

If the desktop is running iTunes (or Linux and a DAAP server), you can play the files streaming on your laptop, and direct the sound to play on your Airport Express and therefore your stereo.
posted by kableh at 3:09 PM on April 11, 2006


I get the idea of this, but I need a little more in terms of specifics. By alias, do you mean a shortcut? Not completely clear. I'm a PC user, BTW.
posted by abbyladybug at 3:09 PM on April 11, 2006


do you mean a shortcut?

same thing, yes.
posted by patricking at 8:53 PM on April 11, 2006


'nother thing about Airport Express: the latest version of Itunes supports streaming to any or all Airport Expresses (Expressi?) in the house. I have one in the living room, one in the kitchen and one upstairs, each outputting to powered speakers. From my wireless laptop I can control music wherever in the house I choose. Perfecto!
posted by Slarty Bartfast at 10:19 PM on April 11, 2006


When I replaced the C-drive iTunes folder on my laptop with an alias/shortcut to the G-drive iTunes folder, iTunes suddenly couldn't see any files at all, despite still being pointed to the G-drive iTunes folder in the preferences. I know the files are still there because I checked. I've tried redragging them into iTunes, but it's too much, and iTunes crashes. I'm stumped.
posted by abbyladybug at 4:10 PM on April 13, 2006


Got your email abbyladybug. It looks like the shortcut thing might not work due to the way Windows treats shortcuts vs how OSX treats aliases. I suggest restoring the iTunes folder on your primary C hard drive.

Due to iTunes limitations it looks like either you'll need to go back to changing the Library location preferences every time or using the Shared Music function.
posted by junesix at 10:03 AM on April 14, 2006


I wish it was just a matter of changing the preferences every time. When I leave the house for any reason, the preference redirects to the C folder. When I change it back to G, it has to rediscover every one of my 12K tracks which takes forever. Now that I did the shortcut thing, it has killed all of my playlists and no longer recognizes any music that is on my G drive. When I try to reconfigure it to import all that music again, it crashes every time. It's not a massive mess, and I'm kind of giving up until I get some more advice, because I think I've messed the whole thing up much worse than it was.
posted by abbyladybug at 10:38 AM on April 15, 2006


Sharing doesn't work, at least when I turn on sharing options in my iTunes preferences, it doesn't allow me to see the files that are on the G drive. When I click Consolidate Library, nothing happens. I can copy files manually from the G drive to the desktop of my laptop, then drag them in to iTunes, and the files seem to go right back to the place I just got them on the G drive. But now I can play them on my laptop. It's such a complete mess, I don't even know what to do. I'm considering uninstalling iTunes from every place and reinstalling it only on my laptop. I wonder if that will work.
posted by abbyladybug at 3:17 PM on April 17, 2006


« Older How do you deal with a family ...   |  I need to apply custom type to... Newer »
This thread is closed to new comments.