Skip

Is it possible to share network/internet connection via a usb dongle (from XP)?
April 7, 2006 10:31 PM   Subscribe

wifi sharing via USB dongle filter: Is it possible to share network/internet connection via a usb dongle (from XP)? if so how?

My mum just purchased a new laptop (ibook) which she would like to connect wirelessly to her home network. She has a wired Linksys broadband modem connected to her WinXP box via ethernet.

I advised her to pick up a wifi usb dongle to share the internet and network from her PC to the iBook, thinking that the dongle could be used to 'push' the netwprk out. With plenty of fiddling the laptop can see the network as a peer to peer but not share the connection to the net.

I'm pretty experienced with the mac side of things but the Windows stuff seems like an endless loop of wizards.

Can anyone point me to set of instruction on how to get this working?
posted by mule to Computers & Internet (7 answers total)
 
Have you made it as far as trying to turn on "Internet Connection Sharing" for the wired ethernet?

1. Start menu, "show all connections" in the "connect to" submenu
2. Right click on the local area connection
3. Choose "properties"
4. Click the "Advanced tab"
5. Check "Allow other users to connect through this computers internet connection"
posted by Good Brain at 10:38 PM on April 7, 2006


Yes, I shared the internet connection as above and selected both the wireless device and the LAN connection and chose to bridge them in the hope that this would push the connection through the uSB dongle, however the 2 won't bridge if the LAN is shared. So I unshared the LAN, bridged the 2 devices again and turned sharing back on but the this didn't seem to work.

At one point in the proceedings we managed to get get the win-box to list as a computer to computer connection in the airport's network list, but this connection was very unstable and proceeding Windows wizards managed to kill this.

On a mac it would be as simple as turning internet sharing and personal file sharing on in the sharing system panel, however, I don't have a clue how to do the same thing through a dongle on Windows.
posted by mule at 12:02 AM on April 8, 2006


The bridging is what's breaking it. You're not bridging, you're running NAT. Disable all bridging, that absolutely won't work. (I've tried... good idea, but it just doesn't work.)

Just right click the external network, choose Properties, go to the Advanced tab, and turn on Internet Connection Sharing.

That should automatically reconfigure the secondary network (the wireless) as address 192.168.0.1, and it will put a simple DHCP server on that network. With the laptop, you tell it to get an address with DHCP, and everything should just work.

It'll be NATting through two layers, but that should be okay.
posted by Malor at 12:26 AM on April 8, 2006


By "external network", I mean the wired connection, btw.
posted by Malor at 12:27 AM on April 8, 2006


Thanks Malor. Killing the bridging and a few other tweaks (making it an ad-hoc network) seem to have allowed the iBook to see the win-box as a router with the IP 192.168.0.1 and has assigned an IP address for the iBook. However, the iBook still is unable to connect to the internet through a browser or browse the domain mshome (which I've configured properly in directory access on the mac).

Using Terminal I am unable to get a ping back from 192.168.0.1

Internet sharing is still turned on on the LAN connection.

What am I missing?
posted by mule at 5:13 AM on April 8, 2006


Is Windows Firewalling turned on? That's all-or-nothing, as far as I know... it runs on every inteface, or none. So don't turn itt off if the machine is connected directly to the outside. If, however, you have another firewall betweeen the Win box and the net, you should be safe turning it off.... at least to test.

If you do want or need to run it, try unblocking ICMP ping, and then seeing if the ping tests from the Mac work. I don't have time right now to give you instructions, and I'll be busy until at least noon MeFi time. If yuo're still stuck, hopefully someone can jump in.

Oh, another thought: Windows insists on using 192.168.0.X for the internal network in filesharing. If the EXTERNAL net is using the same address range (quite common), things are going to go completely bizarre. This would normally happen when you have a hardware firewall/router... most of them also default to 192.168.0.X. Unlike Windows, you can change every router I've seen. Just switch the 'internal' neetwork rabge to some other private IP space. I'd suggest going to something like 192.168.51.X .... by using an oddball number like that, you'll have a low chance of conflicts with other devices you may add later.

I'm sorry I don't have more time right now... hopefully that will get you pointed in the right direction.
posted by Malor at 6:51 AM on April 8, 2006


Might be a Windows Firewall misconfiguration. Try disabling the firewall on the Winbox's wireless connection. If that works, try turning it back on and adding exceptions for ICMP and file sharing.

And if none of that works, install Ethereal all over the place so you can actually see what's going on.
posted by flabdablet at 7:07 AM on April 8, 2006


« Older I need to make the bulbs in a ...   |  Linuxfilter: why doesn't the i... Newer »
This thread is closed to new comments.


Post