Join 3,512 readers in helping fund MetaFilter (Hide)


How can I shut off the auto-click feature of the touchpad on my Sony Vaio?
March 26, 2006 6:39 PM   Subscribe

How can I shut off the auto-click feature of the touchpad on my Sony Vaio (model PCG-GRT170, if that helps)?

I'm assuming this is called auto-click. It's not tapping (which is where tapping on the touchpad acts the same as clicking the left button). I can turn tapping off and it still does this. It's a function where if I move the cursor somewhere, the computer reacts as though I've also clicked there, even though I haven't. I can't seem to find a way to disable this in the mouse options. Google turns up some people with similar problems but no real solutions.
posted by DyRE to Computers & Internet (5 answers total)
 
Sony's esupport site for your model turns up a number of updates, including one for the touchpad driver, which supposedly "Resolves multiple issues and enhances functionality."

I don't know if that will help, but it might be a start. Good luck.
posted by bwilms at 3:43 AM on March 27, 2006


Ahhh, my new Toshiba laptop does this too, and I haven't been able to figure out how to turn it off. It seems like it mostly happens in the corners - if I click in the upper left, it opens the "file" menu. Very irritating. I realize this isn't helpful, but I hope someone else is!
posted by dpx.mfx at 3:43 AM on March 27, 2006


Is there any general touchpad drivers for Windows which does things like turning the trackpad off while the keyboard is in use (an OS X feature, but so far unreplicable on Windows)?
posted by tommorris at 4:27 AM on March 27, 2006


On every PC portable I've every owned, there has been a physical button next to the trackpad which disabled it.

For my current laptop (a Compaq) the touchpad driver placed an icon in the tray. Right-clicking that icon brings up a popup menu, and one of the choices is whether to enable "tap to click". That driver is from a company named "Synaptics", who appear to be the OEM source for the touchpad Compaq used.
posted by Steven C. Den Beste at 4:39 AM on March 27, 2006


bwilms, unfortuantely, shutting off the auto-click function doesn't seem to be one of the 'enhanced' functions. Thanks anyway though. There's plenty of other crap I could stand to update too.

dpx.mfx, this might be the first thing you tried, but have you checked around in Mouse in the Control Panel? My touchpad can do obnoxious 'helpful' stuff like opening menus too but there's a way to disable it under the Functions tab under the Mouse options. Maybe your Toshiba has something similar.
posted by DyRE at 8:24 PM on March 27, 2006


« Older Okay, I have to "look nic...   |  Regex Madness...filter. How do... Newer »
This thread is closed to new comments.