Join 3,558 readers in helping fund MetaFilter (Hide)


How to set up program association for opening folders?
January 12, 2006 2:53 PM   Subscribe

ACDSee has taken over my Windows folders! Or: how to change the program associated with opening folders?

Something happened that caused my Windows to open all folders in ACDSee. When I double-click a folder in Windows Explorer, it will load up ACDSee. Clicking 'Explore' or 'Open' in the context menu for a folder will correctly start up Windows Explorer, however.

I've tried uninstalling ACDSee, but then Windows just asks which program to use to open a folder, but does this for every individual folder, not for the default 'open folder' operation.

How do I make Windows open folder normally again? It is something I can change in ACDsee (I can't find it), or does it require some Windows registry voodoo?

BTW, I'm talking about ACDSee v7.0 build 43 and MS Windows XP SP2 here.
posted by Harry to Computers & Internet (8 answers total)
 
In explorer, go to tools and file options (I think), and somewhere in that dialog there's a list of file types that have associated programs. Get the properties of the "Folder" filetype, select the "explore" entry and hit "set as default". (This is all a bit fuzzy, as it's from distant memory. But with any luck you'll be able to figure it out from this)
posted by fvw at 3:27 PM on January 12, 2006


The filetype "Folder" has an 'explore' and an 'open' option. But whichever I set as the default, it still fires up ACDSee. There's also a filetype called "System Folder" (I have a Dutch Windows, so the actual English term might be different), which has a few ACDSee options, a few Winamp options, but no 'open' or 'explore'. I suspect this is where programs add their context menu addons?
posted by Harry at 3:55 PM on January 12, 2006


Can you:

- Open Regedit.exe and navigate to:
HKEY_CLASSES_ROOT\Folder\shell

You should see explore and open. Setting the default value of both shell\explore\command and shell\open\command to

%SystemRoot%\Explorer.exe /idlist,%I,%L

may work. No promises.
posted by null terminated at 4:05 PM on January 12, 2006


Actually, I may have misread your question.

This page has more information.
posted by null terminated at 4:11 PM on January 12, 2006


Thanks for asking the question - same thing's happened to me and it's been driving me batshit.
posted by SashaPT at 5:53 PM on January 12, 2006


ACDSee is the devil's spawn.

If you're leery of registry editing (me too), try selecting a .jpg file, right click and go to OpenWith=>Choose Program...

Before clicking on Photoshop or PaintShop Pro (or your progam of choice), check the

[ ] Always use the selected program to open this kind of file

box at the bottom. You might have to do this twice before Windows remembers but once remembered ACDSee will no longer have its evil way and demand to be the default application for that type of file.

Do this for each graphic type you regularly open (.jpg, .jpeg, .gif, etc.) and you'll be able to forget the damn thing ever existed.
posted by ceri richard at 6:01 PM on January 12, 2006


I haven't got the faintest clue about what it actually did, but executing regsvr32 /i shell32.dll and setting 'Explore' to the default action like fvw mentioned, fixed my problem. Thanks, Metafilter!
posted by Harry at 6:35 AM on January 13, 2006


Worked for me, too - great!
posted by SashaPT at 6:53 PM on January 13, 2006


« Older I'm thinking of learing to pol...   |  I'd like to have some range la... Newer »
This thread is closed to new comments.