Join 3,572 readers in helping fund MetaFilter (Hide)


Windows home network not working
December 26, 2005 6:51 AM   Subscribe

I'm trying to set up a very simple 2-PC network, with no networking experience, and I can't figure out why it won't work.

I have a old computer (running Windows 98) and a new computer (running Windows XP). I want to transfer lots and lots of files from the old computer to the new, after which the old computer will be given away. So a quick home network connection seems like the best way. They both have ethernet ports, so I'm using a crossover cable that I got from Radio Shack.

I ran the "set up or change your home office network" wizard on the XP machine. These computers do not have internet access, so I selected the options relevant to that. Then, I used the Windows XP install disk that came with the XP machine to run the same wizard on the Windows 98 machine. I named the old computer "OLD," and the new computer "NEW" and made sure I put in the same group name ("LOCK") for both. I restarted when told to do so. But the two computers cannot see each other. I've gone to sites like geekgirls.com looking for clues, but I'm still in the dark. What have I missed?
posted by JanetLand to Computers & Internet (12 answers total)
 
it would probably be easier and faster to remove the hard drive from the old machine and install it as a "slave" drive in the new machine. Data travels over the IDE bus faster than over ethernet.

my guess is you may need a "null modem" cable to do things the way your tring to do them now.
posted by cosmicbandito at 7:19 AM on December 26, 2005


I am not sure if this will help

Or This

Good luck! I tried the same thing and was unsuccessful.
The slave hard drive idea is actually much easier.
posted by Makebusy7 at 7:23 AM on December 26, 2005


perhaps the XP machine's firewall is blocking the filesharing port?

perhaps one or both of the machines's network card is disabled, or perhaps does not have the windows filesharing protocol enabled?
posted by paradroid at 7:23 AM on December 26, 2005


I think you need a router or hub between two computers--you just can't connect them directly as you have described.

You can get them to link using a com port or a parallel port. I haven't done this, but it seems like it would be an easy way to achieve what you want.

Cosmicbandito's idea would work, too.
posted by lester at 7:57 AM on December 26, 2005


Nope, not a null modem, and yes, you can directly connect two ethernet cards together if you use a crossover cable. Do the two cards have "link" lights and are they on? I'm not sure what you meant that you ran the XP wizard on the 98 machine.
posted by AstroGuy at 8:07 AM on December 26, 2005


Connecting the computers directly will work fine if a crossover cable is used as described in the question.

I'm not familiar with XP's network wizard as I never use it. I have a feeling that the network wizard has set up DHCP, which will cause the problem you're describing.

My advice is to go into the TCP/IP settings on each computer and set up static IP addresses. To do this, on the Windows 98 machine (just going off into memory) it's in Control Panel/Network/TCP/IP. Set the IP address to 10.0.0.2 and the subnet mask to 255.255.255.0. Go to the gateway tab and make sure there are no gateways listed. Once you're done, make sure that file sharing is turned on. Click the "file and print sharing" button in the network dialog to do this.

On the XP machine, go to Control Panel/Network Connections/(your network card)/Properties/TCP/IP. Set the IP address to 10.0.0.3, subnet mask to 255.255.255.0, and no default gateway/DNS servers.

After doing all this, it should work properly. If not, I've either forgotten to mention a vital detail or there's a hardware problem.
posted by zixyer at 8:13 AM on December 26, 2005


Disable the firewall on the XP machine and then create an account on the W98 machine that matches the name and password of the one you are using on the XP system. You are doing fine with the crossover cable. Make sure that the ethernet cards are enabled on both systems. Start->settings->Network connections. Then the 98 system should show up in my network places on the XP system.
posted by Ferrari328 at 8:17 AM on December 26, 2005


I've used this guide to transfer data from Win 98 to Win 2000. I passed it onto a (less technically-savvy) friend, who had no problems connecting Win 98 to Win XP. Really clear and detailed.
posted by hangashore at 8:35 AM on December 26, 2005


Thanks for the great responses so far -- I'm not sure I'll be where the computers are today to try any of these ideas (I'm doing this for a friend who is even more clueless than I am), but I'll post a follow-up as soon as possible.
posted by JanetLand at 8:41 AM on December 26, 2005


I had a problem the first time I tried setting up my wireless net with an xp and Win98 box. I thought for sure it was the Win98 machine, but it turned out that the Network Support in Windows Setup was disabled on the xp machine. Once I did that, everything worked fine. Check it out if you're still having problems.

The frustrating thing with that was that the xp box would allow me to set up a network and wouldn't notify that network support was not enabled on that box.
posted by Doohickie at 10:33 AM on December 26, 2005


Just open both machines, remove hard drive from the source machine and add as a second drive to the target machine, copy the files, then put the drive back.
posted by StarForce5 at 6:25 PM on December 26, 2005


zixyer, you da man. You too hangashore. Static IP addresses did the trick. All files are transferred. Better Living Through Technology!
posted by JanetLand at 6:18 AM on December 27, 2005


« Older I need songs with the name &qu...   |  What's the best way to find fr... Newer »
This thread is closed to new comments.