Join 3,572 readers in helping fund MetaFilter (Hide)


RSS feed doesn't validate.
December 15, 2005 10:05 AM   Subscribe

My RSS feed isn't validating, and I can't figure out why...

Running it through the Feed Validator gives me the following error:

XML parsing error: :28:24: unclosed CDATA section

This happens semi-regularly with WordPress, and I haven't been able to track down a suitable answer as to why it happens, even in the WP forums.

Usually I can sniff out a bad character or something, but this time I'm simply stumped, and the post causing the problem is fairly important to me, so I'd like my few RSS subscribers to know about it.

My feed's address: http://o2b.net/feed/

Hope me, hope me!
posted by o2b to Computers & Internet (5 answers total)
 
Well it ends with "<![CDATA[" which is obviously not valid. What's the post that should be there?
posted by null terminated at 10:14 AM on December 15, 2005


It's likely that something in WordPress is throwing an error just as it starts trying to output that post. Try disabling any WordPress plugins you've installed...
posted by mbrubeck at 10:45 AM on December 15, 2005


The problem is the first post on my site (http://o2b.net/). I've removed it and the feed validates. I've picked it apart paragraph by paragraph, and I can't find the culprit.
posted by o2b at 10:45 AM on December 15, 2005


Dammit, I didn't mean to mark my comment as best answer. Sorry.
posted by o2b at 10:49 AM on December 15, 2005


Dangit, I didn't know there was an unmark link, so my last comment sucks too.

Anyway, it was a plugin. Thanks very much mbrubeck.
posted by o2b at 10:50 AM on December 15, 2005


« Older Is there a cell phone equivale...   |  I have a Sony digital camera D... Newer »
This thread is closed to new comments.