Join 3,553 readers in helping fund MetaFilter (Hide)

Tags:

Importing hyperlinks into Excel
August 15, 2014 5:57 PM   Subscribe

As users of Excel may know, only one hyperlink is allowed per cell. I'm trying to import HTML tables in which there are sometimes two hyperlinks per cell. The Excel importer does not seem to like this, so it gets rid of the link. Is there any way around this?

What I am talking about is HTML in which a single TD might look like this:


Here is a pair of links.


But when import it to Excel it looks like this:


Here is a pair of links.


Unless I am mistaken, this doesn't happen where there is just one hyperlink. So I think Excel is stripping it. Any ideas much appreciated. I have tried programatically adding extra TDs to break things up but it has been a headache.
posted by johngoren to Computers & Internet (3 answers total) 1 user marked this as a favorite
 
Did you try unchecking the "Import blocks into columns" box? It's under the "Web Query Options" menu on the right of the pop-up that appears when you use the Data -> From Web sequence. (That's in Excel 2010... I don't know where it is in other versions).
posted by carmicha at 7:07 PM on August 15


What do you want the behavior to be -- retain the first link?
posted by batter_my_heart at 11:52 PM on August 15


I'd be inclined to clean up all whistespace, then flatten out the html tables to CSV, adding newlines after any </tr> and stripping all tags, replacing with say a pipe ( | ) character. I think html tables come with too much overhead, you want to simplify where you can.
posted by artlung at 2:19 PM on August 18


« Older I recently read The Winter Peo...   |  Where do people physically sho... Newer »

You are not logged in, either login or create an account to post comments