Skip

Mac/Google Calendar continues to list EDT/EST months after moving
August 15, 2014 8:41 AM   Subscribe

I have a Google Calendar synced with my Mac (Yosemite) where I had a full year's events added while living in Toronto. I moved 3 months ago to the West Coast and changed all settings to Pacific Time, but when I check on the individual upcoming events from this calendar, I find either the event itself is off by 3 hours (urgh) or the TZ itself is still listed as Eastern (less problematic, but annoying).

I have 'Set time zone automatically using current location' on & 'Set time and date automatically' on with Apple's US servers.

I did some more checking re iCloud after reading this Apple Discussions Forums item about iCloud's TZ support and have confirmed that it is set to Pacific Time correctly.

I gather the TZ support is set when the user enters the event into the calendar initially, so wherever you set the TZ, that's the TZ that gets baked into the event permanently.

Does this mean I have to re-do the events (for the rest of the year, basically) from here? (If so, I'll just do next year's events for this calendar in December.)

Thanks everyone.
posted by northtwilight to Computers & Internet (3 answers total)
 
This is a Google Calendar specific setting.

In Google Calendar, click the gear icon in the upper right, then pick Settings.

Set "Your Current Time Zone" to Pacific.
posted by tckma at 8:44 AM on August 15 [1 favorite]


Wow, thanks!!
posted by northtwilight at 10:08 AM on August 15


No problem.
posted by tckma at 11:47 AM on August 15


« Older I know how to cook in general,...   |  What is a good substitute for ... Newer »

You are not logged in, either login or create an account to post comments



Post