Join 3,561 readers in helping fund MetaFilter (Hide)


How to open "file://" hyperlinks in Internet Explorer 10?
July 28, 2014 9:46 AM   Subscribe

How to open "file://" hyperlinks in Internet Explorer 10?

I'm having a hard time setting the correct settings to allow IE 10 to open file:// hyperlinks.

When I click on a file:// hyperlinks, nothing happens. In Chrome, it opens fine.

From what I research so far, this is a security setting.

I need to enable file:// hyperlinks in both Windows 7 and Windows 8.1.

Thanks for any help!
posted by colecovizion to Computers & Internet (5 answers total)
 
Sorry, I meant IE 11, not 10.
posted by colecovizion at 9:49 AM on July 28


Make sure the page that provides these hyperlinks is in the Trusted Sites zone in Internet Explorer (Tools->Internet options->Security tab).
posted by swoopstake at 11:29 AM on July 28


@swoopstake: Yes, it's already in the trusted sites, but still doesn't work.
posted by colecovizion at 1:30 PM on July 28


Is the file:// link properly constructed?
posted by Aleyn at 5:01 PM on July 28


I figured it out! I was mistakenly adding my domain to the trusted site rather than the external website.

The hyperlink is located on a secure external website page. Example: https://www.mywebsite.com
and it points to a local Windows domain file: Example: file://myDomainServer/myfile.pdf

In Internet Explorer 11 (in Windows 7 or 8.1):
1. Go to Internet Options
2. Go to "security tab"
3. Go to "trusted sites"
4. Go to "sites" button
5. Add the external website: https://www.mywebsite.com. Click "close"
6. Uncheck "Enable Protected Mode"
7. Click "ok"

Now everything works! No registry changes necessary.

Thanks everyone for your help!
posted by colecovizion at 10:31 AM on July 29


« Older I'm housesitting and the loo r...   |  There are a couple bushes in o... Newer »

You are not logged in, either login or create an account to post comments