Join 3,555 readers in helping fund MetaFilter (Hide)

Tags:

Why did Google stop working?
July 24, 2014 1:23 PM   Subscribe

Suddenly, following a link to http://www.google.com or entering www.google.com brings up a page designated as https://www.google.com/?gws_rd=ssl. This does not bring up the search page under Chrome at all, and it's hit and miss under Firefox. I rechecked my self-created home page, where the link usually used resides, and it clearly has http: and not https: Could this be my ISP interfering with the direction of the URL? It's one of the larger ones.
posted by yclipse to Computers & Internet (11 answers total)
 
I suspect that gws_rd stands for Google Web Services Redirect and ssl stands for, well, SSL. So it's just saying it redirected you from http to https.
posted by ambrosen at 1:26 PM on July 24


Google is redirecting you to the secure page. The initial request responds with
Location:https://www.google.com/?gws_rd=ssl
Which causes your browser to go there.
posted by wrok at 1:27 PM on July 24


google is redirecting http users to https nowadays. I also have the http url set as my homepage and get that behavior but the https site works for me.

does google load if you go directly to the https version?

if anything, your isp is interfering with the https, but i find it unlikely
posted by TheAdamist at 1:27 PM on July 24


I just tried typing in www.google.com on my government-job-provided Internet and it redirected the same way, though it does show the search page for me. So at least that rules out the theory that your ISP is redirecting, it looks like Google itself is redirecting to that URL. As to why it's not rendering, I don't know what's going on there.
posted by rabbitrabbit at 1:27 PM on July 24


"ssl" means it's a secure page, as does "https" at the beginning.

It sounds like you entered an insecure url (starting with "http") and google wants you to use a secure one, so they redirected you. I get the same thing if I type "http://www.google.com" in my address bar.

"https://www.google.com/?gws_rd=ssl" works fine for me; it's just a normal google page, but maybe you're in some weird state because of the redirect. Is it possible to just change your homepage to start with "https" instead?
posted by drjimmy11 at 1:27 PM on July 24 [1 favorite]


It looks like this started happening in June and it is Firefox/Google redirecting you to a secure server. So it's actually I good thing and not a bad one. This post may explain it better.
posted by AppleTurnover at 2:05 PM on July 24


If I'm reading the OP correctly, this change is causing Google searches to hang all the time, which is certainly my experience – so even if it's a good thing in principle it's really annoying in practice! I will watch this thread for possible solutions.
posted by oliverburkeman at 2:49 PM on July 24


Try bookmarking (or typing every time) https://www.google.com and see if that will work for you.
posted by rabbitrabbit at 3:18 PM on July 24


I restarted Chrome and that got rid of the "hang" problem, which was the major problem for my wife.

I can redo my URL to https, but it sucks that I have to endure yet another nanny in my life. I have several sites where SSL is needed. Google isn't one of them.
posted by yclipse at 4:58 PM on July 24


I have several sites where SSL is needed. Google isn't one of them.
Why not enable it? It's not like it hurts the performance measurably, and this way people can't overhear/MitM your traffic.
posted by katrielalex at 6:12 AM on July 25


I had this exact problem, clearing my history, including at all computers I use Chrome on, fixed it.
posted by sunslice at 9:33 AM on July 25


« Older I am looking to learn or becom...   |  I am looking to start a progra... Newer »

You are not logged in, either login or create an account to post comments