Join 3,564 readers in helping fund MetaFilter (Hide)


Mac printing only in landscape layout, not portrait, in Firefox
June 23, 2014 4:30 PM   Subscribe

A couple of weeks ago, our office Mac (OS X 10.7.5) started printing everything from Firefox (30.0) in landscape layout (on our HP laserjet CM1312nfi), when we need portrait layout to be the default.

Even though QuickBooks (the program we use most) recently updated itself, that's not the problem, as we can print QuickBooks checks from the other computer (a PC) in portrait layout. I can't print email attachments or web pages in portrait layout either. I enabled Acrobat Reader and PDF plugins, updated Adobe Reader (11.0.7), rebooted the computer, and tried changing the print layout, but one can't change the default settings on the print menu. When I hit print, I see the "Presets" drop-down menu at the top set to "Default Settings." (The 6th line down has "Firefox" set as its default option on the drop-down menu.) Back at the top, I click on "Default Settings," go to "Show Presets" -> "Copies and Pages," click the little arrow, and "Orientation: Landscape" shows up, but I can't change it.

If I change the drop-down menu that has "Firefox" as its default to "Layout," there's a little picture/diagram that shows a sample page with a number 1 in the middle, in layout landscape, but there is no way to change this either; nothing is clickable.

There's nothing in System Preferences or Printer Settings either. Help!

(Forgive me if the answer to this is glaringly obvious, but I've been Googling and reading Mac and Firefox and QuickBooks help forums for several hours, asked folks here, and... nothing. Ready to tear all my hair out.)
posted by Lettuce_Leaves to Computers & Internet (4 answers total)
 
Try this:

1. Open a new tab in Firefox.
2. In the new tab, type about:config in the address bar.
3. Click the button and agree that you understand the risks of proceeding.
4. Search for the print orientation preference by typing print.print_orientation in the search area, or just type print in the search area and scroll until you find it.
5. Default is 0. Try changing that to 1 (or if it is 1, change it back to 0).
6. You may find a specific orientation for your printer -- if so, change that one.

I think the changes are take effect immediately, but if not, quit and restart.
posted by mosk at 4:53 PM on June 23


Could "a couple of weeks ago" be 2 weeks ago, when Firefox 30 came out? If that seems to fit the timeline of the problem, you could try rolling back to Firefox 29.
posted by bcwinters at 8:48 PM on June 23


What does the File/Page setup menu tell you?
posted by epo at 1:38 AM on June 24


The last one did the trick! Thanks, all.
posted by Lettuce_Leaves at 8:01 PM on June 24


« Older I'm a person who excels very w...   |  Product recommendations for lo... Newer »

You are not logged in, either login or create an account to post comments